[SOLVED] Removing a Thing

Tags: #<Tag:0x00007fc1f96791a8>
  • Platform information:

    • Hardware: Raspberry Pi 3
    • OS: OpenHabian
  • Issue of the topic:
    I have a GE door sensor ZW 6301, z-wave. I had added it as a Thing in Paper UI, then I wanted to remove and re-add because I an not sure it was working ok and I added it to my SmartThings hub and it checked out ok. I removed it from Smartthings. Now I have it with battery removed and start PaperUI and it is discovered in the Inbox (Yes even with battery removed) So I think this must be something left from prior install, but what?
    As a related question, the standard way to remove or add a z-wave thing to most systems you need to put the system into add or remove mode then press a button on the thing, OpenHab does not seem to work that way.

  • Please post configurations (if applicable):

    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
  • If logs where generated please post these here using code fences:

Have you stopped OH and cleaned the cache?

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo systemctl start openhab2

If you still have an item or link then you can remove them from:
/var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.link.ItemChannelLink.json and make sure there isn’t a Link hanging around. Also, for items check: /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.items.Item.json

Just be sure to stop OH first if you edit these files.

You did not say you excluded it from the Z-Wave network. That information is stored on the controller. If you reset the device and joined it to a different Z-Wave network, you now have a zombie node on this controller’s network which can cause you network issues.

What you can TRY is to discover the Thing, mark it ad a Failed Node, Exclude/Remove it from the network, and then delete the Thing.

If that does not work, there is software, mainly Windows based, that can remove the node from the controller’s network.

This is an issue with Z-Wave network management, not openHAB or Thing related directly.

@Bruce_Osborne , I left that step out of my post. I did try to remove it from OpenHAB by clicking the trash can icon beside it on the PaperUI>Configuration>Things page and it did disappear from list. But there was no instruction or time to click the button in the thing itself, as I would have to do in SmartThings.

@H102 the cache clean did not change anything, I will try @Bruce_Osborne suggestion and then if that does not work will I will do your other suggestion.

That will not clear it from the Z-Wave b network stored on the controller.

Sometimes, even when Excluding a node it can still stay as a zombie on the controller.

This is also the same with openHAB. Unfortunately, it’s not as well integrated as one may like as openHAB restricts what the binding can do. So, you have to put the system into remove mode, then remove the device by pressing the button on the device.

You will then however need to delete the thing from openHAB. When the binding was first written, this was done automatically, but since then openHAB stops the binding doing this so it must be done manually.

1 Like

Thanks to all.
After I did your suggestions it was still there but I saw an option to do a hard reset of the z-wave controller and looks like everything ok.

Please tick the solution, thanks

1 Like

Why it is so difficult to get rid of obsolete things and items? I switched my Zigbee devices from the internal Zigbee binding to zigbee2mqtt and now I need to get rid of the old things from the Zigbee binding. The Zigbee binding is uninstalled, the userdata/zigbee data folder is deleted.

  1. I tried to use PaperUI to remove the old Zigbee things and items.
    No luck, PaperUI showed “Removing”, after the next start of openHAB all removed things were still there, but “uninitialized”.

  2. I stopped openHAB, deleted the contents of the userdata/cache and userdata/tmp folders.
    After the next start the Zigbee items were still there, “unintialized”.

  3. With openHAB stopped, I cleared cache and tmp again, then edited the JSON files in userdata/jsondb and removed all traces of the Zigbee things, items, links and whatever.
    After the next start the Zigbee items were still there, “unintialized”.

  4. I run openHAB in a docker container. So I deleted that image and re-started the docker container from scratch with the data from step 3) above (cleared cache and such). And guess what? The Zigbee things were still there, “uninitialized” :confounded:

What can I do to finally get rid of them?

Because you removed the binding, you must force remove the things.

The system expects the binding to confirm they are REMOVED. Since you remove the binding this doesn’t happen and you must click the delete button again in PaperUI to force remove it.

1 Like

I removed the binging way after first trying to delete the things with PaperUI…

Did you try force removing the things?

I now did after re-installing the Zigbee binding. I did not know that I could force-removing a thing that is already in the “removing” state.
Thanks Chris for the hint, the obsolete things are gone (for now) :wink:

1 Like