[SOLVED] Rrd4j and chart [null error]

  • Platform information:
    • Hardware: RaspberryPi 3b
    • OS: OpenHabian
      • openHAB version:2.5M3
  • Issue of the topic: Cannot generate Charts
    Hi all, I have a problem to create a chart of my items:
    My items file:
  	Number          ControlloCarichi_Ch1TrasmissionePotenza         "Consumo istantaneo [%.2f KWh]" <energy>        (gControlloCarichi)     {channel="knx:device:89dfb93f:44"}

My rrd4j.persist:

Strategies {
// for rrd charts, we need a cron strategy
everyMinute : “0 * * * * ?”

    default = everyChange


Items {
// persist items on every change and every minute
ControlloCarichi_Ch1TrasmissionePotenza : strategy = everyChange, everyMinute
OutdoorTemp_Clima_Sala : strategy = everyChange, everyMinute

My sitemap:

   Frame label="grafico"    {
                            Chart item= OutdoorTemp_Clima_Sala period=D refresh=30000 service="rrd4j"

My logs:

2019-09-09 16:08:46.941 [WARN ] [thome.ui.internal.chart.ChartServlet] - Chart generation failed: null

I have the items files in /var/lib/openhab2/persistence/rrd4j but I don’t know how to check if they are populated with data. Only stranges configuration is that I made a LINK of /var/lib/openhab2/persistence/ to an external disk…

Checking whether the rrd-file contains any entries can be done using the REST API ( install REST Docs to get it).
Read here on how to check for values.

In case you do have values stores it could be related to this issue., which is solved by installing fontconfig.

Good morning Opus, thanks for your time.
I don’t know if it’s normal but that are the rest results:


[ ]

And so on…

So, what is strange for me is that second query (myserver:8080/rest/persistence/items?serviceId=rrd4j) result empty… Do you think is my case the second one? I’ll try to install fontconfig

Install the fontconfig packet solved the problem! You made my day :smiley:
$sudo apt install fontconfig

That is normal, the request for all items for a specific persistence Service never workerd (I think).

I’m glad you got it working. Do you remember from when your original openhabian installation was? Mine is rather old (> 1 year+) and I haven’t run into this issue and as you saw that issue should be solved for actually downloaded version.

My installation is 6-8 month old :confused:

Thanks, that fits. Issue was solved in July.

1 Like