[SOLVED] Rrd4j persists issue with strategy "everyChange"

charts
Tags: #<Tag:0x00007f0142c383c8>

(Dennis Lang) #8

Hi,

Thank you, here the intesting part!

Chart item=HeizungCurrentTemp period=h refresh=30000

BR


(Angelos) #9

remove the space after the Group name


(Dennis Lang) #10

Already done - but it still not work!


(Angelos) #11

did you add everyMinute to the Group’s persistence?

HeizungCurrentTemp* : strategy = everyMinute, everyChange, restoreOnStartup, //bei jeder Änderung des Wertes wird dieser gespeichert

Which Items are members of the HeizungCurrentTemp Group?
If you list the Group, you don’t need to list the individual Items belonging to the Group in your rrd4j.persist


(Dennis Lang) #12

Are members of the Group “HeizungCurrentTemp”


(Angelos) #13

in this case, you only need to list the Group to cover them
any additional Items which are not members of this Group, you can list them individually (but remember to add the everyMinute strategy in your rrd4j.persist

do you have more than 1 persistence service installed? or only rrd4j?


(Dennis Lang) #14

You are right, thank You - Now I deleted the individual Items which member in the Group and the indevidual Charts still working! But I cannot see the Multiple Chart of the group.

only this peristence


(Angelos) #15

I don’t know if there is any limitation with regards to how many Grouped Items can be displayed on a single graph (you have 7 Items now)

Try the following: Create another Group, put only 2 Items as members, add it in persistence and try to graph this on your sitemap

Ps: If you want advanced graphs, take a look at: InfluxDB+Grafana persistence and graphing


(Dennis Lang) #16

Already tried! Also with 2 items it ins not working!


(Angelos) #17

Kim can provide the solution (joking):
image

I really don’t know what is wrong… your Chart element looks correct to me
maybe leave some time to pass for the system to collect some data in persistence and then try to display the graph?


(Jürgen Baginski) #18

Me too! I created a chart with a 2 member group just last night and don’t see the problem. The last Point you didn’t post so far (Definition of Group and items) seems to be correct (otherwise the persistence would have stopped).


(Angelos) #19

I found something (very old) from the wiki: https://github.com/openhab/openhab1-addons/wiki/Explanation-of-Sitemaps#element-chart

Maybe this was patched (or maybe not… i didn’t check github)

Can you post your Items to be checked?


(Dennis Lang) #20

I will read this for advanced graphs - may I switch to this!

Many thanks for you support!


(Dennis Lang) #21

This will be the problem I guess all Labels of the Items are “Aktuelle Temperatur [%.1f °C]” - so not unique


(Angelos) #22

so this issue of the rrd4j persistence coming from OH 1.7 times (that’s before 2015! :stuck_out_tongue:) has not been patched :slight_smile:
try to change the labels and report back plz :slight_smile:


(Dennis Lang) #23

Jepp - now it works! Many thanks!


(Angelos) #24

image


(Jürgen Baginski) #25

I am curious on that question too and I’m doing a test ATM. Configured a rrd4j database for taking only one reading per houre and will report the finding.
Regarding the strategy “everyChange” IMHO that will have no observable different result, because such an entry, which is not inline the expected timeperiod, will be only be used to calculate the next expected reading. If the next reading is coming as expected, the consolidation function will be used to calculate, if the expected reading is missing, the additionally reported reading will be used.


(Markus Storm) #26

Bottom line is it’s as @rlkoshak pointed out you need a number of values per timeframe for rrd4j to work properly, so ‘everyChange’ isn’t enough.


(Jürgen Baginski) #27

My rrd4j.cfg contains:

Tester.def=GAUGE,360,U,U,3600
Tester.archives=MAX,.5,1,24:MAX,.5,24,30:MAX,.5,30,12
Tester.items=TestNumber

TestNumber is given the strategy “everyHour” .

Using the DEBUG log I get the usual 2 entries when a value is written into the DB (the old one written again and the new one), those entries are logged only at the full hour (as expected using the strategy).

HOWEVER, doing a REST call for this item shows now entries into the DB! (Which would be the reason for not showing anything on a Chart) The Setup is running for mor then 10 now. Looks to me as if the db doesn’t take any entries, but why? The .rrd file however has the actual time of now, as if something got into it!