[SOLVED] Rrd4j persists issue with strategy "everyChange"

charts
Tags: #<Tag:0x00007f014bf0e3f0>

(Dennis Lang) #21

This will be the problem I guess all Labels of the Items are “Aktuelle Temperatur [%.1f °C]” - so not unique


(Angelos) #22

so this issue of the rrd4j persistence coming from OH 1.7 times (that’s before 2015! :stuck_out_tongue:) has not been patched :slight_smile:
try to change the labels and report back plz :slight_smile:


(Dennis Lang) #23

Jepp - now it works! Many thanks!


(Angelos) #24

image


(Jürgen Baginski) #25

I am curious on that question too and I’m doing a test ATM. Configured a rrd4j database for taking only one reading per houre and will report the finding.
Regarding the strategy “everyChange” IMHO that will have no observable different result, because such an entry, which is not inline the expected timeperiod, will be only be used to calculate the next expected reading. If the next reading is coming as expected, the consolidation function will be used to calculate, if the expected reading is missing, the additionally reported reading will be used.


(Markus Storm) #26

Bottom line is it’s as @rlkoshak pointed out you need a number of values per timeframe for rrd4j to work properly, so ‘everyChange’ isn’t enough.


(Jürgen Baginski) #27

My rrd4j.cfg contains:

Tester.def=GAUGE,360,U,U,3600
Tester.archives=MAX,.5,1,24:MAX,.5,24,30:MAX,.5,30,12
Tester.items=TestNumber

TestNumber is given the strategy “everyHour” .

Using the DEBUG log I get the usual 2 entries when a value is written into the DB (the old one written again and the new one), those entries are logged only at the full hour (as expected using the strategy).

HOWEVER, doing a REST call for this item shows now entries into the DB! (Which would be the reason for not showing anything on a Chart) The Setup is running for mor then 10 now. Looks to me as if the db doesn’t take any entries, but why? The .rrd file however has the actual time of now, as if something got into it!