[SOLVED] Rule execution curious behaviour

  • Platform information:
    • Hardware: Raspberry Pi3
    • OS: openhabian buster (actual stable)
    • Java Runtime Environment: I think Zulu, which was auto installed
    • openHAB version: 2.4

I have multiple Sonoff basics which communicate over mqtt and mosquitto. I did the complete configuration in paperUI, what works absolutely correct. I can turn the switches and read the sensor data plugged in the Sonoffs.

For the role management I installed the experimental rule engine. There I created two rules for my tank-light. It should turn the light on at 8am and turn off at 8pm (Fixed time - send command - ON / OFF). After creating I tested the rule with the “play” button and it works.

But when the time comes, nothing happens. If I toggle the switch manually at 8.01pm the light turns on/off. So, connection is there. Now I go into the rule management and press the play button, nothing happens. Then i open the rule and click on a gear (eg for fixed time) and save again (I changed nothing!). After this the rule worked again on pressing the play-button.

I didn’t know why this happens. Any ideas?

Thank you :slight_smile:

possibly related

There are some known bugs in managed rules in 2.4 and this sounds like one of them that I believe had been fixed by version 2.5 M3. You need to upgrade.

Also, hell in mind that experimental in the name. Serious bugs like this are not barriers to a new release of OH. Features are added and breaking changes made without warning. And they’re us little documentation and even fewer people here able to help with problems on it right now.

I did an system upgrade to openhab 2.5 M3 and it seems that the rules are working again. Thanks for helping me :slight_smile: