[SOLVED] Rules strange behaviour ,work perfectly, then 3-4 hours latter stop working

Tags: #<Tag:0x00007f186fdeec28>

Platform information:openhabian
Hardware: Rpi3b+
openHAB version:2.5M5

hi , i have some strange problem with some rules, i create the rules and it work perfectly, then 3-4 hours latter stop working, i need to refresh the rules by modify somes thing …save and it work for a couple of houres.

here is the rules

rule "Drapeau Arretier OFF alors Snoopy OFF"

when   
            Item AmbSalonSouper changed from ON to OFF   //is a switch light btcino f411
then             
            
            logInfo("AmbSalonSouper", "AmbSalonSouper OFF")   
            PlafondSalonMyhomeDimmer.sendCommand(0)   //is a switch light btcino f411
            SalonArretierTableDimmer.sendCommand(0)   //is a switch dimmer btcino
            PlafondCusineMyhomeSwitch.sendCommand(OFF)  //is a switch dimmer btcino           
            
end    



rule "Activation ambiance Souper "

when   
            Item AmbSalonSouper changed from OFF to ON 
then   
            logInfo("AmbSalonSouper", "AmbSalonSouper ON")   
            PlafondSalonMyhomeDimmer.sendCommand(20)
            SalonArretierTableDimmer.sendCommand(80)
            PlafondCusineMyhomeSwitch.sendCommand(ON)                
    
end

the only error i see in the log “not frontail” is this

[et.handler.OpenWebNetLightingHandler] - ==OWN:LightingHandler== updateLightOnOffState() Ignoring unsupported WHAT for thing openwebnet:bus_on_off_switch:F454_000350a47e32:11. Frame=<*#1*11*1*200*3##>

thanks for helping me , this is strange…i have 2 rules having the same behaviour, running perfectly then a couple of hours laters…is like sleeping…juste need to open the rules modify some things then saving and voila…working again…for couples hours

Have you tried cleaning the cache and rebooting OH? May have something lingering in cache that is causing the issue.

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo reboot

The rules shown both trigger from the same Item. Does that Item actually change -check your events.log ?

thanks a lot for your help ! so i find the cause and is mine…

the problem was the “label of the rule” as the same as another “label” in a file .rules so i’m stupid…yes .
is not so easy to find because i never recieve a warning or a error in frontail.

anyway thanks a lot for helping me !

It is a bit sneaky not reporting an error, but the system doesn’t know that a duplicate rule name is not just you editing it.

yes, so is a stupid error of myself…:flushed: