[SOLVED] Shelly1 with Tasmota/Sonoff - headlamp switch does not work

Hello,
I flashed my Shelly1 with Tasmota.

Stat: stat/sonoff/power1
Command: cmnd/sonoff/power1

When I press the heatlamp switch, the light switchs to off immediately. Only when I toggle the switch at Openhab the light stays on.
Did I something wrong?

Thanks
Tobias

Is your device really named “sonoff”,would be weird if you have more then one and it is a Shelly not a Sonoff.
If the device is has only one switch (Shelly1?) there is no Power1, it is only POWER (uppercase)!

1 Like

Hi Jürgen,
the name was sonoff but I changed it.
Oh correct, it should be POWER instead of power1.

My current configuration is:

The problem still exists. When i’m pressing the heatlamp switch the light turn on and off immediately.
Do I have to configure teh switch type like here?

Thanks
Tobias

What is the "heatlamp"or “headlamp switch”? A hardware switch on the Shelly? Does the Shelly have such?
Where is that copied from? Does it relate to Tasmota? You did flash your device to Tasmota ( the web interface shown is from Tasmota!)
You can use the web interface to monitor which messages/commands are received by the Shelly. Use the Console on the Main page.

I ment the hardware wall mounted switch. The dark screenshot above is from the shelly1 with the original firmware.

Got it, i had to change the switch type to 4, because I need a momentary switch:
https://github.com/arendst/Sonoff-Tasmota/wiki/Buttons-and-Switches

Thanks
Tobias

Glad you got it. Please mark this thread as resolved the selecting any post as the solution (Checkmark icon on the lower end of every reply).