[SOLVED] Smartwares Wireless Sensor (Lighting2)

Hello,
I was trying without success to connect a Smartwares Wireless Door Sensor to my OpenHAB 2.0.0 instance (via RFXCOM receiver)

When I use my RFXCOM manager : I see the following in the log

Open Door


Packettype = Lighting2
subtype = AC
Sequence nbr = 1
ID = 1640400 decimal:23331840
Unit = 2
Command = On
Signal level = 7 -64dBm

Close Door



Packettype = Lighting2
subtype = AC
Sequence nbr = 6
ID = 1640400 decimal:23331840
Unit = 2
Command = Off
Signal level = 7 -64dBm

My Thing Configuration looks like this :

Switch GarageDoor “Garage Door” (gGarage) { rfxcom="<23331840.2:LIGHTING2.AC:Command" }

However, I see nothing happening in OpenHAB. Nothing in the log either.

This parameter “Enable AC messages to RFXCOM transceiver.” is set to true in the RFXCOM conig of OPENHAB2.

Any idea of the problem ?

Thanks for your help

Thibaut

Are you sure? I assume that you see in the log following line for GarageDoor item (during startup)?

RFXCOM binding must contain two parts separated by ‘:’

Which means that your item configuration syntax doesn’t follow the guide.

in: rfxcom="<DeviceId:ValueSelector"
out: rfxcom=">DeviceId:PacketType.SubType:ValueSelector"

In binding doesn’t need protocol information(packet type and sub type) as it’s only need by the RFXCOM controller to know exactly how to transmit data. See more details from wiki

Correct syntax is

Switch GarageDoor “Garage Door” (gGarage) { rfxcom="<23331840.2:Command" }

Thanks Pali,
It worked after your update + update of the “setMode” option of the rfxcom receiver config file (enable the AC protocol listening)
This parameter was set in the HABmin apps, but apparently, it is not sufficient…

Thibaut

I’m trying to get this to work in openhab2 but with no luck so far. According to the documentation, only lighting2 actuators are supported, not sensors.

Is there a syntax for getting this defined as an input in OH2 rfxcom?