[SOLVED] [SOLVED] Missing RULE_ID at 'label=' after updating oh2

Tags: #<Tag:0x00007f61667436e0> #<Tag:0x00007f61667435a0>

I updated my oh2 to oh2.1 and now one of my sitemaps doesn’t load with follwing error:

[WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model ‘default.sitemap’ has errors, therefore ignoring it: [1,219,16]: missing RULE_ID at ‘label=’
[1,224,16]: missing RULE_ID at ‘label=’

What does this mean? Line 219 and 224?

I suggest loading your sitemap into Eclipse Smarthome Designer 0.8. There is a syntax error or something like that which is making your sitemap unparsable.

What does [1,224,16] mean?

line 1224 character 16

Thanks for all this.

What does “missing RULE_ID” actually mean?

I’ve only got three items in my file, becuase I can’t create Group:Color items in PaperUi

Group:Color:OR(ON, OFF) gKitchenColorPicker    "Kitchen Colour Picker" 	<colorwheel> 	()

Group:Color:OR(ON, OFF) gBedroomColorPicker    "Bedroom Colour Picker" 	<colorwheel> 	()

Group:Color:OR(ON, OFF) gTherapyColorPicker    "Therapy Colour Picker" 	<colorwheel> 	()

I see this entry in /var/logs/openhab.log when I load the .items file

2018-07-17 12:50:03.518 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'Group_Color.items' has errors, therefore ignoring it: [1,88]: missing RULE_ID at ')'
[3,88]: missing RULE_ID at ')'
[5,88]: missing RULE_ID at ')'

2018-07-17 12:50:04.601 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'Group_Color.items' has errors, therefore ignoring it: [1,88]: missing RULE_ID at ')'
[3,88]: missing RULE_ID at ')'
[5,88]: missing RULE_ID at ')'

The usage will be that I have 3 universes of DMX lighting in a room, which as an option I would like to set the one colour.

I thought I could create 3 x DMX Color (RGB) Dimmer with items linked to the Color element, that are then grouped to a single color picker.

Do I have to do it all in an .items file?

Like this post ?

I changed the .items file to this and it loaded.

Group LED

Group:Color:OR(ON, OFF) gKitchenColorPicker    "Kitchen Colour Picker" 	<colorwheel> 	(LED)

Group:Color:OR(ON, OFF) gBedroomColorPicker    "Bedroom Colour Picker" 	<colorwheel> 	(LED)

Group:Color:OR(ON, OFF) gTherapyColorPicker    "Therapy Colour Picker" 	<colorwheel> 	(LED)

And it appears to be working

That is a new error message for me. Very odd.

If I were to guess I’d say it doesn’t like the empty Group membership field. What happens if you remove the empty ()?

That probably works because the () are no longer empty.

1 Like

Thanks for the feedback Rich :smile:

Fabulous support as always.

I’m tempted to try removing the LED group… But now it’s working…

1 Like