[Solved] Something break in latest builds? - getting Couldn't invoke 'assignValueTo' for feature JvmVoid: errors

So I had everything working great on build #469. When I went to upgrade to 470 on Sunday it wiped my config and unfortunately my latest backup didn’t save right. So I had to go back to some old rules but they shouldn’t have changed much.

Using this statement in a rule:

SunRiseTime = DateTime((astro_sun_local_rise_end.state as DateTimeType).calendar.timeInMillis)

Is generating this error:

2016-09-13 08:05:00.590 [ERROR] [ntime.internal.engine.ExecuteRuleJob] - Error during the execution of rule Sunrise: An error occured during the script execution: Couldn’t invoke ‘assignValueTo’ for feature JvmVoid: (eProxyURI: Sunrise.rules#|::

I have SunRiseTime defined as:

var DateTime SunRiseTime

I have also verified that I’m able to pull the state for astro_sun_local_rise_end

Any suggestions would be appreciated.

Tried a clean install to test and it’s still kicking off the error.

Could you enter an issue at https://github.com/eclipse/smarthome/issues with a simple example to reproduce (e.g. using the demo files and a simple new rule added to demo.rules)?

Will do, thanks.

Question, is there a repository someplace of older builds so I can go back 10 days or so before the error since I can only find a couple back on cloudbees?

No, unfortunately, we do not have that much space on Cloudbees to keep those builds.
The only older builds that are retained are the alpha and beta versions at https://bintray.com/openhab/mvn/openhab-distro.


So it looks like some sort of user error. When I simplified the rule down to just a logging rule is started working. I added back in the commends one at a time and it now works. I must have had a typo someplace that I was missing. Sorry for wasting your time on this one.