[SOLVED] Sonoff iFan03

First the required info:

Raspberry pi3 w/ Openhabian. Everything up to date. Mosquitto MQTT broker and the Sonoff iFan03 is running the latest Tasmota firmware. Everything has been done via the PaperUI.

Created the thing for the iFan and then added two channels, one for the light and one for the fan. Then I tied these too items, a switch for the light and a number entry for the fan.

The light works perfectly, it sends the command, gets the update. So no matter where the light is turned on the UI shows it’s correct status.

The fan on the other hand is giving me some trouble. Openhab has no issue sending the correct number and ifan jumps to that setting. I am just not getting the update back. So if I turn it from 0 to 3 outside of OpenHab there is no update.

My command topic (which works) is:


My update topic is:


My incoming transformation is:

(MQTT.fx shows that the result topic is being sent as {"FanSpeed":0} where 0 is the speed 0 - 3).

Is there something else I need to set to get this to work? Is there an issue with the transformation?

Also, how do I create a switch with 4 buttons for this, rather than needing to enter a number? Or is that just something that gets taken care of when the widget is created on the control panel?

Well I worked it out. I needed to actually install the JSON translation service, and I needed to take out the quotes from the line in the thing.

So back on track and chugging away :smiley:

1 Like