SOLVED: Sony projector serial over IP


  • Platform information:

    • Hardware: Synology DS420+
    • OS: DSM6 / Docker
    • Java Runtime Environment: 8
    • openHAB version: 2.5.1 container
  • Issue of the topic:
    I am trying to use the Sony projector binding for serial-over-ethernet control of a VPL-HW55ES. I have a USRIOT-W610 Wifi 2 RS232 unit configured for the Sony RS232 protocol details and have it connected to the projector via a null modem cable. I have verified the config of the interface (including the IP address and port shown below) by testing with a laptop with an RS232 port.

I have the Sony projector binding installed and a thing definition:
Thing sonyprojector:serialoveripconnection:hw55 “Projector” [ host=“”, port=8234, model=“VPL-HW55ES” ]
and an item example:
Switch Projector_OnOff “Power” (gCinemaAVPower) { channel = “sonyprojector:serialoveripconnection:hw55:power” }

The log gives me a connection error:
11:16:40.126 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘sonyprojector:serialoveripconnection:hw55’ changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Opening serial over IP connection failed: Connection refused (Connection refused)

I guess the port parameter for in the thing declaration is the port on the interface. I also exposed the same port from the OH docker container, and configured the interface for 8234. If I sound confused about this, yes I am…

I am not sure how to troubleshoot this further. Any help would be greatly appreciated.


Either a docker setup problem or a problem with the setup of your USRIOT-W610 Wifi 2 RS232.
The error is clear, the connection is refused.

For your information, I am using the binding with serial over IP without any problem but with a more standard setup.

Thanks. The port is confusing me. Is the port parameter in the thing declaration the port on the OpenHAB host or the IP/serial device? If the latter, how do I know what port on the OpenHAB host I should be using, or is only the IP address significant?

Port to access the serial device.
Normally your serial to WiFi converter should allow you to set this port or define one to be used.

@Lolodomo Thanks for helping with this. It appears that I have fixed it. The USRIOT interface documentation is not fantastic. I had it set to Transparent Client mode, because that is what I understood to be appropriate. Apparently not, Transparent Server mode works. You then don’t specify the OH host IP, as I guess OH makes the connection to the interface that acts as the server for the RS232 device. No changes needed in OH or docker, though I did previously expose port 8234 in the container config.