[SOLVED] SSD busy all the time

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Rev 1.2
    • OS: openhabian / Raspbian GNU/Linux 9 (stretch)
    • openHAB version: 2.2.0
    • Transcend SSD370S interne SSD 32GB (6,4 cm (2,5 Zoll), SATA III, MLC)

Hi everyone,

i moved root to an external ssd.
My problem is that the ssd is in action all the time.
The Idicator LED is busy alle the time. This might be not healthy.
The System ist stable. No Problems.
Any ideas?

This is my rrd4j.persist

Strategies {
   everyMinute	: "0 * * * * ?"
   everyHour    : "0 0 * * * ?"
   everyDay     : "0 0 0 * * ?"
   default = everyChange

Items {
WohnzimmerThermostat : strategy = everyChange, everyMinute, restoreOnStartup
graphtemp* : strategy = everyChange, everyMinute, restoreOnStartup
Proxytmp : strategy = everyChange, everyMinute, restoreOnStartup
Essbereich : strategy = everyChange, everyMinute, restoreOnStartup
Outside : strategy = everyChange, everyMinute, restoreOnStartup
switch* : strategy = restoreOnStartup

Did you ever change logging levels? Run log:get in Karaf to see what the levels are set to. You could also run something like this to see which files have recently been changed (just change to the current time and the correct folder for your install)…

ls -alR /opt/openhab2|grep "Mar 23 12:08"

Other than log files, I see a lot of writes to resolver-status.properties and org.eclipse.smarthome.core.thing.Thing.json. I’m running 2.3.0 snapshot 1238 though.

I’ll check grep this weekend.


openhab> log:get
Logger                                             │ Level
ROOT                                               │ WARN
javax.jmdns                                        │ ERROR
org.apache.karaf.jaas.modules.audit                │ INFO
org.apache.karaf.kar.internal.KarServiceImpl       │ ERROR
org.apache.karaf.shell.support                     │ OFF
org.eclipse.smarthome                              │ INFO
org.jupnp                                          │ ERROR
org.openhab                                        │ INFO
org.ops4j.pax.url.mvn.internal.AetherBasedResolver │ ERROR
org.ops4j.pax.web.pax-web-runtime                  │ OFF
smarthome.event                                    │ INFO
smarthome.event.InboxUpdatedEvent                  │ ERROR
smarthome.event.ItemAddedEvent                     │ ERROR
smarthome.event.ItemRemovedEvent                   │ ERROR
smarthome.event.ItemStateEvent                     │ ERROR
smarthome.event.ThingAddedEvent                    │ ERROR
smarthome.event.ThingRemovedEvent                  │ ERROR
smarthome.event.ThingStatusInfoEvent               │ ERROR
smarthome.event.ThingUpdatedEvent                  │ ERROR
smarthome.event.thingipdatedevent                  │ ERROR

This is what i see in iotop. Can someone tell me more about this?
These jar files are located in openhab2-sys\runtime\lib\boot

Does anyone have a tip?

I see the same symptom even without moving the root to the SSD.
Anyone know why?

Meanwhile my Router (fritzbox) has crashed. Ive got another Router (different fritzbox) now without Internet connection. Openhab is runnig only in the LAN. The ssd is now less aktive. Maybe its the taffic to the Cloud connector or ifttt. I will check it when my Router is back using whireshark.
Can you reproduce this?

Do you have a milight iBox2? Eveything ist fine when my iBox is offline (powerless).
@David_Graeff can you give a hint?

Milight iBox2
Binding 2.2.0
openhabian 2.2

Solved it. Stopped the bindig. Run bundle:update via Karaf and start the bindig again.