[SOLVED] Support for new device

aeotec
zwave
binding
Tags: #<Tag:0x00007f1e6e2d9e78> #<Tag:0x00007f1e6e2d9d10> #<Tag:0x00007f1e6e2d9ba8>
(Lorenzo Thurman) #1

I was not able to find this device in the database:
model number ZWA003

Aeotec Nanomote Quad

So I take it that its not currently supported by the 2.4 version of the zwave binding. Is there a development version of the binding that supports it? If so, how does one switch to it?

Thanks

0 Likes

(Mark) #2

Correct.

The device needs to be added to the database, after which it will be included in a 2.5 snapshot release of the zwave binding. Once the binding is updated, to pick up the new device, you’ll need to update your zwave binding to the latest 2.5 snapshot.

You can add the device to the database. If you have the device, uploading the node.xml file from the userdata/zwave directory will speed up the process as it pre-populates the database with information queried from the device. This is all described in the linked document here.
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

Edit: Please post back here if you run into any questions/issues along the way.

1 Like

(Lorenzo Thurman) #3

Great, thank you. I will do this sometime this week.

“My Break-Dancing days are over, but there’s always the Funky Chicken” – The Full Monty

0 Likes

(B K) #4

See also here:

Until the snapshots work again, the new Zwave binding (along with its updated database, won’t be available…

0 Likes

(Lorenzo Thurman) #5

How does one generate the xml file? I thought including the device would create one, but that did not happen and the linked doc does not explain it.
Thanks

0 Likes

(Mark) #6

The binding generates the xml file automatically after it has completed initialization for the device. For mains-powered devices, this usually happens in a matter of several seconds. For battery-powered devices, this can take a while as the device needs to wake up multiple times. You can speed this up by manually waking up the device multiple times.

So in the case of the Nanomote, try waking it up repeatedly until the xml file is created. If the Nanomote is anything like the Minimote and the Wallmote, those devices don’t wake up on their own, so it may require manual wake ups.

0 Likes

(Lorenzo Thurman) #7

I uploaded the XML, but got a number of errors. The endpoints appear to be defined correctly, but some metadata appears not tb defined.

This device has received the following updates since the last review.  **Note:**  Review can not be performed until all above errors are removed!

2019-02-10 17:42:05 Uploaded XML
0 Likes

(Lorenzo Thurman) #8

I’m having a problem getting the new device properly recognized. Can someone tell me how to update the missing/bad fields? @mhilbush @bartus
Thanks

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1006

0 Likes

(Mark) #9

Do you have edit access for the database? If so, complete the following fields. If you don’t have edit access, post the information here and I’ll update the database.

* `thingid` is > 15 characters - is this really necessary - it should just be the model number.
* `thingid` should not contain manufacturer name.

Change the thingid from aeotecnanomotequad to something shorter and without the manufacturer name. Maybe ZWA003, which I think is the product number.

* Overview information is not set
* Inclusion information is not set
* Exclusion information is not set
* Wakeup information is not set

Fill in these fields from information you get from the manual.

* At least one manufacturers product image must be uploaded

Find an image of the product (e.g. from manufacturer’s web site) and upload it to the database.

0 Likes

(Lorenzo Thurman) #10

Thank you. I was able to add the info. Should be OK now.

0 Likes

(Lorenzo Thurman) #11

Two more follow-up questions:

How do I know if a given snapshot build has the updated binding?
Is there a change log for the snapshot builds?

0 Likes

(Mark) #12

There’s no change log, per se. But, the commit history of the zwave binding (if you are so inclined to keep an eye on it) will show the changes to the binding.

For new device additions, or changes to existing devices, you would want to look at the Database Updates. In this case, the ZWA003 was added 6 days ago. Therefore, it is in the current snapshot version of the binding.

You don’t need to update the entire openHAB installation. You can just update the zwave binding as described here.

Post back here if you run into any issues.

0 Likes

(Lorenzo Thurman) #13

I just want everyone to know that I installed snapshot zwave binding and it got my new device working.

Thanks for all the help, it was really appreciated.

1 Like

(Keith T Garner) #14

lazloman, I’ve gotten my nanoremote paired, but I can’t seem to get it to do anything reliably. (Occasionally it might update the battery info.) Any tips to get it working (or rules/items entries to use?)

0 Likes

(Lorenzo Thurman) #15

Here’s any example rule I use:

rule "Nano Mote Quad received update"
when 
Item car_mote_quad_scene_number received update 
then 

val scene = car_mote_quad_scene_number.state as DecimalType

if(scene == 1.0 || scene == 2.0 || scene == 3.0){
    if(Garage_Switch.state == OFF)
        Garage_Switch.sendCommand(ON)
    else 
        Garage_Switch.sendCommand(OFF)
} else if(scene == 4.0) {

    if(Desk_Light_Switch.state == OFF){
        Desk_Light_Switch.sendCommand(ON)
    }
    if(PatioLight_Switch.state == OFF){
        PatioLight_Switch.sendCommand(ON)
    }
}
end

i hope this helps. The NanoMote works just fine for me.

0 Likes

(Keith T Garner) #16

I must have had something gone wrong in pairing or some other issue. I’m not getting updates at all when I press the buttons. I’ll have to bang my head against this more tomorrow.

Thanks for the help!

0 Likes

(Lorenzo Thurman) #17

I would say exclude and include the device again.

0 Likes

(Keith T Garner) #18

I did that a few times. Looks like the 2.5 snapshots weren’t setting the association group. We’ll need to add that configuration to the definition (something on my todo for this week.)

In the mean time, I used the open zwave control panel to set the Assocation to 1 and it started working perfectly.

Commenting to close the loop and for future people like me who may end up looking here :slight_smile:

0 Likes