[SOLVED] Synology Zigbee Binding and CC2531 Stick - "failed to open the dongle"

I am trying to replace my Hue bridge by adding a Zigbee CC2531 USB Stick at my Synology running openHab

I attached the USB Stick and can see it at /dev/ttyACM0:

someuser@DS918plus:/volume1/someuser$ ls -l /dev/ttyACM0 
crw------- 1 root root 166, 0 Sep  2 03:34 /dev/ttyACM0

Adding the thing as well:

Thing zigbee:coordinator_cc2531:stick1 "Zigbee USB Stick" [zigbee_port="/dev/ttyACM0", zigbee_baud=38400, zigbee_panid=35637, zigbee_extendedpanid="118E309DE90CC829", zigbee_networkkey="14 c6 a2 c7 fb e0 c3 19 8e 7c 36 30 dc ad a5 96"]

results in this error:

2019-09-02 19:23:08.065 [ERROR] [ding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyACM0 does not exist.

2019-09-02 19:23:09.663 [ERROR] [.cc2531.network.ZigBeeNetworkManager] - Failed to open the dongle.

I have read about adding the openhab user to specific groups and allowing him the access to the USB ports. What I have tried is adding the user to the administrators temporarily without success. I have no clue how I can specifically allow the USB port access on a Synology DSM system.

Any idea what I could try next?

The problem is the ownership. As I don’t use synology, I don’t know how to change this (persistent :wink: ).
But as a first test, just try

sudo chmod 777 /dev/ttyACM0

before starting openHAB.

While not related to the issue you report, I would strongly advise you to use a newer version. 2.3 is very old and the ZigBee binding has received a LOT of updates in the past year or more since 2.3 was released. You will likely have problems with such an old version that I won’t be able to support.

Thanks for the quick reply @Udo_Hartmann.
I executed the command after stopping openHab.

someuser@DS918plus:/volume1/someuser$ ls -l /dev/ttyACM0 
crwxrwxrwx 1 root root 166, 0 Sep  2 03:34 /dev/ttyACM0

After starting openHab again the stick is shows as online:



So I will research on how to change the ownership persistently.
I do not find any bulbs searching for them in PaperUI but I guess that is a different issue.

I will update. Thanks for the hint.

@in1t5 How did you manage it? I am having the same problem. My OpenHAB on a Synology cannot access the zigbee stick.