[SOLVED] TACMI addon not visible in openHAB2

I am running openHAB2 on a PI3 and have successfully connected to all my Homematic devices and can control them.
Now I want to also read out and control my heating system via the Technische Alternative CMI web interface. All prerequisites have been performed as per this documentation: TACMI-Binding. I also followed this instruction an how to implement the binding in openHAB2 : TA CMI - need help [solved]. I put the org.openhab.binding.tacmi-1.9.0.b4.jar file in the openhab2-addons folder and created the tacmi.cfg file in the openhab2-conf/services folder.
But somehow I am not able to see anything of the supposedly connected TACMI. Nor can I find any of the created items.
What am I overseeing?
Thanks for any help.
And, by the way, I seem to not being able to log anything. The openhab2-logs/*.log are not being updated and the karaf log:display does not produce any output, despite log:set info.
Any idea here?


Maybe try a newer jar file.

good try and thanks for the link.
Nop. No difference.

Perhaps I need to take a step back and ask a few more basic questions:
Should my manually defined items appear in the PaperUI items list? Because they do not.
Should the items be visible in the HabPanel items list? They are also not there.
I have created a sitemap manually and inserted a few Homematic items. They were all created automatically and they all display values in the BasicUI. I have equally inserted some of the manual items which do not display anything.
Therefore, I believe there is a more fundamental problem.
What do I have to do if I want to use a 1.x binding with openHAB2? Do I only copy over the *.jar file and create a config?

Turn on legacy bindings in PaperUI then you’ll have all the 1.x bindings.

Of course this was my very first attempt. But this binding is not listed on OH. This is why I manually put the *.jar file in the addons folder and created the tacmi.cfg file.
I was wondering whether I have to somehow tell OH that it needs to use this binding. Or should it automatically recognize it through the config file? But then, why doesn’t it?


It should be auto recognized but you can stop OH and restart just to be sure. Have you checked the karaf console to see if it’s listed?


230 │ Active │ 80 │ │ openHAB TACmi Binding

last in the list.
The one you suggested earlier.

Should it now be visible anywhere else. E.g. in the Habpanel?

sorry, in the PaperUI, I meant

It should be listed under Configuration > Bindings in PaperUI

unfortunately not.
I have Astro, Homematic, NTP, Yahoo Weather. All of which are version 2.4.

Did you stop and restart OH?

sudo systemctl stop openhab

sudo systemctl start openhab
sudo reboot

half a million times
I did
sudo systemctl restart openhab2.service

and it is currently restrating again, just to be sure.

same list of bindings after restarting openhab2.service

In the bundle list do you have org.openhab.binding.tacmi at the end?

should it actually say org.openhab.binding.tacmi ?
because it states
230 │ Active │ 80 │ │ openHAB TACmi Binding
indicating that it recognized the correct version of the *.jar file. (as written earlier)

Looking at the link you posted above they have org.openhab.binding.tacmi at the end so I was just wondering if maybe it was there and just no posted in the reply.

I’ve tried looking on github but nothing found.:neutral_face:

I was not entirely correct earlier. I have installed two more bindings of versions lower than 2.x
211 │ Active │ 80 │ 1.13.0 │ openHAB ComfoAir Binding
225 │ Active │ 80 │ 1.13.0 │ openHAB RRD4j Persistence Bundle
and of course
213 │ Active │ 80 │ 2.4.0 │ openHAB 1.x Compatibility Layer

Of which the rrd4j is working. I can use it to produce charts.
The ComfoAir is for a ventilation system. I will tackle this after the TACMI is working. So diregard this one for the time being.

But all three do not show up in PaperUI’s bindings list.
Perhaps they don’t have to and can still work. Then, how do I know whether they receive any data, since the corresponding items do not show any values?

Maybe you need the feature:install openhab-runtime-compat1x for this binding to work.

Do you see anything regarding this binding and it’s items in front tail logs?

The compatibility layer was installed already. But I have still done feature:install openhab-runtime-compat1x
No 1.x bindings listed in PaperUI.

log:display displays exactly nothing.
log:tail waits with an empty line until I stop it (after minutes).
Log files in openhab2-logs date March 18th, strangely. And, yes, system time is set correctly :slight_smile:

I also updated OH through openhabian-config.

Any more ideas?
And thanks for being so patient.

After a good night’s sleep I decided to use another Pi that I had idle and do a fresh install of openHABian, go through the procedures as stated above and voila, I can now read out temparatures from the heater controller.
I have no explanaition why. I have certainly not played with this particular binding before. But the openHABis installation sat on the bench for some months and was recently updated. Perhaps some settings were changed in the process.
Anyway, I will now transfere all other configs from the other system and see how this goes.

Thanks for your input. I learned quite a few things.