[SOLVED] Thing unable to be approved: Cannot add element, because an element with same UID already exists

  • Platform information:
    • Hardware: Raspberry Pi Model 3B+
    • OS: Openhabian
    • Java Runtime Environment: Zulu
    • openHAB version: 2.4
  • Issue of the topic: please be detailed explaining your issue

i can’t add a thing to my openhab configuration… the thing in question is my Phoscon-GW ( somehow openhab claims it already exists … but its neither listed in the Thing section nor did i define it anyway in a .things file
I simply tested defining it in the .things file but openhab still refuses to list it in the Configutation.Things section of the Paper UI.
It is lying in my Inbox though … ready to be added … or maybe not

  • Please post configurations (if applicable):
    • Items configuration related to the issue
      No Items defined yet …
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
Bridge hue:bridge:00212E02F47B                  "Phoscon Bridge Büro" [ ipAddress=""] {    

this is how i tried to add it in the things file … but even when i add it, its a no show in the paper UI.
I somehow assume there is an item stuck somewhere in openhab that wasnt deleted when i deleted the bridge a few days ago.

  • If logs where generated please post these here using code fences:
2019-01-06 15:46:05.338 [ERROR] [ore.internal.discovery.InboxResource] - Thing hue:bridge:00212E02F47B unable to be approved: Cannot add element, because an element with same UID (hue:bridge:00212E02F47B) already exists.

If you have deleted the bridge created in paperUi then clean the cache and make sure that auto discovery is not enabled.

sudo systemctl stop openhab2

sudo openhab-cli clean-cache

sudo reeboot
or if you prefer to not reboot
sudo systemctl start openhab2

this is the screenshot of the UI. It says in the bottom, Error 404 - Not found … when it click the hook symbol

ok, will try that.

ok, that worked, thx a lot. the bridge isnt autodiscovering its items, but that is another topic maybe…

Glad I could help.:smiley:

Thanks for editing the title to start with [Solved].:+1: If you would please click the square box on the post that provided the solution.



EDIT: @Schelli Just guessing,:crossed_fingers: as I don’t use these devices, you may need to reset them before a link to the new bridge will happen.

oh, cool tip with the solution checkbox, added that to all my solved topics … cool feature.