[SOLVED] Things power cycled, now rule doesn't work

Hey guys,

I’m running OH2.2 on a Synology DS218+ with DSM 6.1.7-15284 and JRE 8.0.151-0014

A few months ago I installed two TP-Link light switches (one hs200 and one hs220) in the same room. The hs220 dimmer carried my light load, and the other hs200 I installed as a dummy without a load. In OH i added both switches as hs200s since the binding support for the hs220 is still kind of flaky and would be too complicated for what I wanted to do. Yes, this did work. Obviously I have no control over the dimming function of the hs220 in OH, but that is irrelevant to me, as long as I can turn it on and off (and I can). I then turned to the community to come up with a set of rules to “link” the two together, essentially making a three way switch. With the help in the community, we made something that worked. Here are the rules:

rule “CPKitchen1”
Item CP_Kitchen_Lights changed
val cpmasterstate = CP_Kitchen_Lights.state
CP_Kitchen_Slave.sendCommand (cpmasterstate)

rule “CPKitchen2”
Item CP_Kitchen_Slave changed
val cpslavestate = CP_Kitchen_Slave.state
CP_Kitchen_Lights.sendCommand (cpslavestate)

This functioned perfectly. And it did for several months. No issues at all. Even with numerous power outages, once everything powered back up, it all went back to proper operation.

That is until now…I recently swapped the two switches (we wanted the dimmer in the other location since it gets used more frequently). Nothing else changed except for which switch was in which box in the wall. Now the rule doesn’t work. I’ve tried renaming the file, adding/removing a blank line in the file to ensure that it was initialized, I’ve tried removing and re-adding the things, and still no luck. I can’t get it to work anymore. What am I missing here?? Literally nothing changed except the switches’ physical locations. HELP!

I’m going to try and update everything I can. I usually avoid doing that unless something is broken. So I’ll report back on if that fixes anything.

okay…I updated the OS on my DS218+ and now its working again…soooo i guess this solves my problem. Thanks anyways

Just for completeness and other people who might read this thread. HS220 (dimmer) support is available in 2.4 (currently snapshot version) and also in the Market place binding. The market place binding most likely won’t work with OH 2.2 due to interface changes in OH.