[SOLVED] Two new Z-Wave devices added to database not showing/working

The one you added is using a dimmer channel. Is that what you want?

I’ve imported the XML generated after I added the device. I would think this would be a “blinds” channel not “dimmer”, but if this is what the XML had, I have to suppose this is the right one or am I missing something?

Also, the other parameters I’ve copied from the blinds device. Should I check them somewhere?

Not an area that I have studied deeply. However, I do know that sometimes the default channel from the OH generated XML is not the best. A quick look at a few blind devices; some have “dimmer”, but some have “blinds control”. Both have a percent property, but the “blinds_control” has a “stop/move” and “up/down” property also. I don’t have any of these devices, so cannot give a definitive answer, but IMO I think you could change to blinds_control without a problem. Another alternative would be to add a blinds_control channel to the multiswitch CC, but I don’t know if that might mess something up. The advantage of that would be that you could try either (once the device is approved) and see what works best for you.

1 Like

This seems definitely like a good aproach and then fix the one that works best!

How could I do that though? :smiley:

In edit mode on that tab look for the add endpoint. Use the same command class as dimmer.

edit: oops that was from memory that must be failing. look for “New Channel” within the same CC

1 Like

Awesome, just did it. Now it’s a matter of waiting! :slight_smile:

I know there is a place to download the snapshot sooner instead of waiting for OH updates. Do you know where is it?

openHAB-ZWave [Jenkins]

See [SOLVED] Two new Z-Wave devices added to database not showing/working - #2 by apella12.

1 Like

@apella12 Guys, I need your help.

I’ve added this other device using all proper proceedures step-by-step. I was the one adding other devices such as this one and it all works like a charm, so it’s not my first time successfully adding a new device.

Now, problem is, this device that I’ve now added twice, I am not being able for it to be added correct apparently, because in this documentation we can clearly see COMMAND_CLASS_CENTRAL_SCENE and that one is never showing in the XML when I view it, so when I import the XML, it does not appear in the Endpoint.

Is there any way for me to add that missing command? Is it even necessary? If not, what am I doing wrong for the system not to find the device?

I am getting a little bit crazy with this here… :frowning:

I’m confused. Is this a new issue? I see the links to two devices that work like a “charm”, but not the one that was added twice. Can you post the xml with the problem device?

Also I think the blog on the DB website covers your scenario?

No, it’s still related to the very same issue, unfortunately.

No, actually the first one (this one) is not working and it’s the one associated with the documentation I shared on the link above.

The second link yes, it’s one example of a device I’ve previously added successfully and it’s working fine.

Regarding the XML for the device when it syncs with OpenHAB, here it is:

<node>
<homeId>0xfc527a9e</homeId>
<nodeId>98</nodeId>
<version>4</version>
<manufacturer>0x267</manufacturer>
<deviceId>0x0</deviceId>
<deviceType>0x106</deviceType>
<listening>true</listening>
<frequentlyListening>false</frequentlyListening>
<routing>true</routing>
<security>false</security>
<beaming>true</beaming>
<maxBaudRate>40000</maxBaudRate>
<sleepDelay>500</sleepDelay>
<nodeInformationFrame>
<commandClass>COMMAND_CLASS_ZWAVEPLUS_INFO</commandClass>
<commandClass>COMMAND_CLASS_ASSOCIATION</commandClass>
<commandClass>COMMAND_CLASS_ASSOCIATION_GRP_INFO</commandClass>
<commandClass>COMMAND_CLASS_TRANSPORT_SERVICE</commandClass>
<commandClass>COMMAND_CLASS_CONFIGURATION</commandClass>
<commandClass>COMMAND_CLASS_VERSION</commandClass>
<commandClass>COMMAND_CLASS_MANUFACTURER_SPECIFIC</commandClass>
<commandClass>COMMAND_CLASS_DEVICE_RESET_LOCALLY</commandClass>
<commandClass>COMMAND_CLASS_POWERLEVEL</commandClass>
<commandClass>COMMAND_CLASS_SWITCH_MULTILEVEL</commandClass>
<commandClass>COMMAND_CLASS_FIRMWARE_UPDATE_MD</commandClass>
</nodeInformationFrame>
<associationGroups class="concurrent-hash-map">
<entry>
<int>1</int>
<associationGroup>
<index>1</index>
<maxNodes>0</maxNodes>
<name>Lifeline</name>
<profile1>0x0</profile1>
<profile2>0x1</profile2>
<commands>
<commandClass>COMMAND_CLASS_DEVICE_RESET_LOCALLY</commandClass>
</commands>
<associations>
<associationMember>
<node>1</node>
</associationMember>
</associations>
</associationGroup>
</entry>
<entry>
<int>2</int>
<associationGroup>
<index>2</index>
<maxNodes>0</maxNodes>
<name>Control</name>
<profile1>0x20</profile1>
<profile2>0x1</profile2>
<commands>
<commandClass>COMMAND_CLASS_BASIC</commandClass>
<commandClass>COMMAND_CLASS_SWITCH_MULTILEVEL</commandClass>
<commandClass>COMMAND_CLASS_CONFIGURATION</commandClass>
<commandClass>COMMAND_CLASS_MANUFACTURER_SPECIFIC</commandClass>
<commandClass>COMMAND_CLASS_ASSOCIATION</commandClass>
</commands>
<associations/>
</associationGroup>
</entry>
</associationGroups>
<endpoints class="concurrent-hash-map">
<entry>
<int>0</int>
<endPoint>
<deviceClass>
<basicDeviceClass>BASIC_TYPE_ROUTING_SLAVE</basicDeviceClass>
<genericDeviceClass>GENERIC_TYPE_WALL_CONTROLLER</genericDeviceClass>
<specificDeviceClass>SPECIFIC_TYPE_BASIC_WALL_CONTROLLER</specificDeviceClass>
</deviceClass>
<endpointId>0</endpointId>
<secureCommandClasses/>
<supportedCommandClasses class="concurrent-hash-map">
<entry>
<commandClass>COMMAND_CLASS_NO_OPERATION</commandClass>
<COMMAND__CLASS__NO__OPERATION>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>1</versionSupported>
</COMMAND__CLASS__NO__OPERATION>
</entry>
<entry>
<commandClass>COMMAND_CLASS_BASIC</commandClass>
<COMMAND__CLASS__BASIC>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>2</versionSupported>
<isGetSupported>true</isGetSupported>
</COMMAND__CLASS__BASIC>
</entry>
<entry>
<commandClass>COMMAND_CLASS_SWITCH_MULTILEVEL</commandClass>
<multiLevelSwitchCommandClass>
<version>3</version>
<instances>1</instances>
<control>false</control>
<versionSupported>4</versionSupported>
<switchTypePrimary>DOWN_UP</switchTypePrimary>
<switchTypeSecondary>UNDEFINED</switchTypeSecondary>
<isGetSupported>true</isGetSupported>
</multiLevelSwitchCommandClass>
</entry>
<entry>
<commandClass>COMMAND_CLASS_ASSOCIATION_GRP_INFO</commandClass>
<COMMAND__CLASS__ASSOCIATION__GRP__INFO>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>3</versionSupported>
<autoSubscribeGroups>
<int>1</int>
<int>2</int>
</autoSubscribeGroups>
</COMMAND__CLASS__ASSOCIATION__GRP__INFO>
</entry>
<entry>
<commandClass>COMMAND_CLASS_DEVICE_RESET_LOCALLY</commandClass>
<COMMAND__CLASS__DEVICE__RESET__LOCALLY>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>1</versionSupported>
</COMMAND__CLASS__DEVICE__RESET__LOCALLY>
</entry>
<entry>
<commandClass>COMMAND_CLASS_ZWAVEPLUS_INFO</commandClass>
<COMMAND__CLASS__ZWAVEPLUS__INFO>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>2</versionSupported>
<zwPlusVersion>2</zwPlusVersion>
<zwPlusRole>ROLE_TYPE_SLAVE_ALWAYS_ON</zwPlusRole>
<zwPlusNodeType>NODE_TYPE_ZWAVEPLUS_NODE</zwPlusNodeType>
<isGetSupported>true</isGetSupported>
</COMMAND__CLASS__ZWAVEPLUS__INFO>
</entry>
<entry>
<commandClass>COMMAND_CLASS_CONFIGURATION</commandClass>
<COMMAND__CLASS__CONFIGURATION>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>4</versionSupported>
<configParameters/>
</COMMAND__CLASS__CONFIGURATION>
</entry>
<entry>
<commandClass>COMMAND_CLASS_MANUFACTURER_SPECIFIC</commandClass>
<COMMAND__CLASS__MANUFACTURER__SPECIFIC>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>2</versionSupported>
<initSerialNumber>false</initSerialNumber>
<deviceManufacturer>615</deviceManufacturer>
<deviceType>262</deviceType>
<deviceId>0</deviceId>
</COMMAND__CLASS__MANUFACTURER__SPECIFIC>
</entry>
<entry>
<commandClass>COMMAND_CLASS_POWERLEVEL</commandClass>
<COMMAND__CLASS__POWERLEVEL>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>1</versionSupported>
<powerLevel>0</powerLevel>
<powerTimeout>0</powerTimeout>
</COMMAND__CLASS__POWERLEVEL>
</entry>
<entry>
<commandClass>COMMAND_CLASS_FIRMWARE_UPDATE_MD</commandClass>
<COMMAND__CLASS__FIRMWARE__UPDATE__MD>
<version>1</version>
<instances>1</instances>
<control>false</control>
<versionSupported>5</versionSupported>
</COMMAND__CLASS__FIRMWARE__UPDATE__MD>
</entry>
<entry>
<commandClass>COMMAND_CLASS_ASSOCIATION</commandClass>
<COMMAND__CLASS__ASSOCIATION>
<version>2</version>
<instances>1</instances>
<control>false</control>
<versionSupported>2</versionSupported>
<maxGroups>2</maxGroups>
</COMMAND__CLASS__ASSOCIATION>
</entry>
<entry>
<commandClass>COMMAND_CLASS_VERSION</commandClass>
<COMMAND__CLASS__VERSION>
<version>2</version>
<instances>1</instances>
<control>false</control>
<versionSupported>3</versionSupported>
<libraryType>LIB_SLAVE_ENHANCED</libraryType>
<protocolVersion>7.16</protocolVersion>
<applicationVersion>1.14</applicationVersion>
<hardwareVersion>2</hardwareVersion>
</COMMAND__CLASS__VERSION>
</entry>
</supportedCommandClasses>
</endPoint>
</entry>
</endpoints>
<nodeNeighbors>
<int>3</int>
<int>14</int>
<int>18</int>
<int>20</int>
<int>23</int>
<int>75</int>
</nodeNeighbors>
<lastReceived>2023-09-20 05:06:39.54 UTC</lastReceived>
</node>

Information on this XML is actually different from the information I see on the oficial documentation for the device (regarding versions) so now I actually changed that to what is in the documentation instead of leaving the information as it is in the XML file (since that didn’t seemed to work).

I’ve done that and I found no help for my case.

What am I missing here eventually?

Thank you in advance!

I’m still not getting it. So what is “not working” after one year; the blinds? What are you trying to do?

During inclusion the device advertises its CC in the NIF frame. If the Central Scene CC is not advertised, I’m sure what to do. Note that your docs have a parameter 28 and 29, not in the DB. Maybe that would help?

Also noted a nearly identical device in the DB with the label (2003)

We are probably not looking into the same things then.

The device I am talking about is the SimonTech S.L.U 10002081-13X S100 iO Master Roller Blind, not the SimonTech S.L.U 1000X080-XXX S100 iO Roller Blind (2023). This second one I just added recently and I hope it’s correct (haven’t even tested yet because reviewer didn’t even had time to do anything since I just very recently added it).

The first one, the “Master Roller Blind” device is one I’ve added once in the past and then I later added again. The one I previously added and I already clicked multiple times in “Mark Deleted” (NOT WORKING) is this one: SimonTech S.L.U 10000306-039 IO Master Simon 100 (I need this one deleted from the database because it’s a previous duplicate from the one I’ve then added afterwards, maybe there’s some kind of conflict here).

The way this “Master Roller Blind” actually works is: it connects with a Hub from Simon and that Hub then receives the commands from the device and sends z-wave commands to other devices, setup in their APP to interact however the user wants to.

In my case, I do not have a Hub because that’s what OpenHAB is used for, so I don’t need to use their APP at all.

But I am not even being able for OH to recognize the device at all and that’s the problem here.

I would open a ticket on the DB to remove. Only the DB admin can remove a device.

Also you can’t add a device with the same number, so this I do not understand this:

EDIT: maybe this will help.

Devices are recognized by the MFG:TYPE:ID string. There are 4 entries of blinds for MFG 0267 (SimonTech) and all have different TYPE:ID, so there are no duplicates. 1) For instance, for your XML that device is 0267:0106:0000. 2) The one you want to delete is 0267:0005:0000. 3) The 2003 one is 0267:0102:0000 and 4) there is an older(?) one with many pairs after the 0267. (0004:0000,0004:0022,0004:0063,0004:0091,0004:0092,0004:0093,0004:0094,0004:0177). All appear nearly identical. If a new device is identical to one in the DB, you can just add the new TYPE:ID pair like was done in the last device I referenced. No upload necessary.

1 Like

Thank you so much for your help!

What if there are different versions on the parameters classes? Does that matter or not?

If the parameters are different, it should be a new device.

Besides the XML posted (0267:0106:0000), how many SimonTech blinds controllers do you have? Also looking at the UI (or the XMLs in the Userdata/Zwave folder) what are the TYPE:IDs ? Just trying to get a handle on your situation.

1 Like

If we are talking about these Masters, 7 units. If we are really talking about normal blinds controllers, 26 controllers.

For this Master, in the “Unknown” device disconvered I see 0 as deviceid.

Ok that looks right compared to the XML. What is the type?

then what are other 6 that are working? Trying to align with the DB listings…

EDIT: Should have asked this from the beginning; What version of OH are you on?

v3.4.0

Device type appears as 262.

There are many of these, these and these that are correctly working.

You know what, the weird thing is that I’ve uninstalled and installed again zwave and now I have almost all masters being detected and recognized but one that is still as Unknown (which is weird because it’s exactly the same as all the others).

Also, I cannot detect anything I do with the buttons, I get no information on OH so I cannot create any rules. Why does this happen?

The answer is the “unknown” has a model number that was added to the zw db after 3.4.0. You need to upgrade.

Edit: it’s late here give me to tomorrow to look at it closer.

EDIT2:

Longer explanation: As noted above, it is NOT the same (at least with the info you provided so far). It may look the “same” on the outside, but SimonTech has changed to numbers that the ZWave binding uses to identify the devices.

As a side note I was looking for the TYPE:ID of only the 6 “Masters” that were working, not you non-masters or switches because I had a concern the ZW DB device you wanted to delete was one of the working ones Something like

Master Node Type ID
7 xx xx
8 xx xx
9 xx xx
10 xx xx
11 xx xx
12 xx xx

Regardless, Type:ID 262:0 (0x0106:0x0000) was added after version 3.4.0, so you will need to update either OH or the Zwave binding. Also to get your recent DB editing reflected, you will also need to update again. I did notice that the last 3.4.x update was in May. I don’t know how to find that, but if you do, that is an option besides the obvious OH4 route (Needs Java17 and has other breaking changes).

The other option is to use this file
1000208113x_0_0.xml (9.1 KB)
and this procedure
Update ZWave binding with new/updated device xml - Tutorials & Examples - openHAB Community
to update the Zwave binding you are currently using. Do a backup first.

1 Like

Thank you for all your help! I see that the snapshot is ready for the changes I made and the new device I added, so I will try to use it and see if everything starts to work.

Just one last question is you can help me with it: do you have any idea why I can’t catch any physical interaction with the Master buttons? I mean, it doesn’t matter if I press UP or DOWN in the Master blinds switch, I cannot make OH to perform any rule or action based on that since it seems that no communication is received apparently.

EDIT: I also do not understand why, but after the manual installation, no zwave binding appears, although in Karaf when I do “list -s | grep zwave” I do see the correct version that I’ve manually installed in addons.

It is not the first time I manually install a zwave binding but clearly this time I am not doing something correct because I have the same problem on two servers, which do not make any sense and it is for sure something I am not doing correctly. I’ve followed your instructions here and I also checked here if something was missing, but I simply cannot find where’s the problem since all seems, supposedly, correct. :frowning:

EDIT2: Actually, I just noticed that it says “Installed” instead of “Active”.
image

EDIT3: Saw online the command to “stop” and thought in trying “start” and this appeared:
image

EDIT4: @chris Sorry to bother you directly, but can this be something with the compiled package itself? I mean, I’ve searched all over and I simply cannot find a way to fix this. :cry: