[SOLVED] Two new Z-Wave devices added to database not showing/working

The one you added is using a dimmer channel. Is that what you want?

I’ve imported the XML generated after I added the device. I would think this would be a “blinds” channel not “dimmer”, but if this is what the XML had, I have to suppose this is the right one or am I missing something?

Also, the other parameters I’ve copied from the blinds device. Should I check them somewhere?

Not an area that I have studied deeply. However, I do know that sometimes the default channel from the OH generated XML is not the best. A quick look at a few blind devices; some have “dimmer”, but some have “blinds control”. Both have a percent property, but the “blinds_control” has a “stop/move” and “up/down” property also. I don’t have any of these devices, so cannot give a definitive answer, but IMO I think you could change to blinds_control without a problem. Another alternative would be to add a blinds_control channel to the multiswitch CC, but I don’t know if that might mess something up. The advantage of that would be that you could try either (once the device is approved) and see what works best for you.

1 Like

This seems definitely like a good aproach and then fix the one that works best!

How could I do that though? :smiley:

In edit mode on that tab look for the add endpoint. Use the same command class as dimmer.

edit: oops that was from memory that must be failing. look for “New Channel” within the same CC

1 Like

Awesome, just did it. Now it’s a matter of waiting! :slight_smile:

I know there is a place to download the snapshot sooner instead of waiting for OH updates. Do you know where is it?

openHAB-ZWave [Jenkins]

See [SOLVED] Two new Z-Wave devices added to database not showing/working - #2 by apella12.

1 Like