[SOLVED] Ubiquiti UniFi 2.4 Binding detection improvement?

I am using the 2.4 UniFi binding from the release version of OpenHAB. Works great connecting to my UniFi Controller software and detecting when I’m here. Real fast pulling that up. It’s when I leave it’s a problem. I have seen 6+ minutes before the controller software sees I have left and am no longer on my Wi-Fi. I have seen where I will manually refresh a device if I turn off the Wi-Fi and it will update, but just refreshing the main connected devices screen can take a long time to figure out I’m gone. Anyone else experience this? Have a solution for speeding up the UniFi app check interval? It’s gotta know what’s still connected to it or not no?

Thanks.

JR

You can set the UniFi screen refresh to 15 seconds, though I’ve no idea if that will help with your problem.

Ira

The Thing parameter [considerHome](https://www.openhab.org/addons/bindings/unifi/#considerhome) is what you need to tweak. I’m not sure what its default setting is, but you could try decreasing the value of considerHome until you see the state of the online channel flapping. I have considerHome set to 90 seconds here, but to be honest, I haven’t paid much attention to whether or not any flapping occurs when I leave the house.

1 Like

Interesting. Thanks Scott. I’ll give that a try. Didn’t catch that setting. For me I wonder if I would have to worry about flapping and wonder if this will work. Couple items:

  1. I have updated a setting for DTIM on my access points that basically my iPhones never seem to drop off the network anymore ever. So in theory no false readings or accidental drops.

  2. When I do drop the connection, the controller still shows the device connected. So do not think the binding will see the device as gone no matter what I set it to. So in theory, if the client stays in the controller console for 6 minutes after I leave, if I set that setting to 0 I would think it will still take 6 minutes before it detects I’m gone? But maybe wrong.

Thanks. Will try this and see how it works.

Thanks.

JR

You should be able to search your events.log for changes to the states of items linked to your online and uptime channels for clues.

Thanks Scott. You da man. I am not sure if this is smart based on your thoughts, but I dropped Consider Home Interval down to 30 seconds. Dropped my iPhone’s WI-Fi, switched over to a timer, and started it. I got an alert 30.35 seconds later. So guess even though the device shows in the UniFi Controller console, technically it knows the device hasn’t reported in but keeps it listed for a period before removing it.

Thanks.

JR

1 Like

Glad to hear that addressed your issue. To help others who may encounter the same issue in the future, please mark your issue as solved.

Cheers!

Marked your post as the Solution before. Did I need to do something else or is it not showing?

Thanks.

JR

No, I had not noticed that you had already taken care of it, thank you. It’s become a “do it by rote” request I guess.