[SOLVED]Unable to rebuild org.openhab.ui 3.2.1-SNAPSHOT jar

Hi,

I am wondering whether it is possible to rebuild 3.2.1 MainUI as I am getting the following error which I assume jfrog does not maintain 3.2.1-SNAPSHOT for all openhab dependencies? Otherwise, what is the best way to rebuild it without going to 3.4.x? I need 3.2.x because this is the version that Im running as I am not ready to move to 3.3 or 3.4.x . Following is the error after running mvn install clean -X

Caused by: org.apache.maven.project.DependencyResolutionException: Could not resolve dependencies for project org.openhab.ui.bundles:org.openhab.ui.reactor.bundles:pom:3.2.1-SNAPSHOT: The following artifacts could not be resolved: org.openhab.core.bom:org.openhab.core.bom.compile:pom:3.2.1-SNAPSHOT, org.openhab.core.bom:org.openhab.core.bom.compile-model:pom:3.2.1-SNAPSHOT: Failure to find org.openhab.core.bom:org.openhab.core.bom.compile:pom:3.2.1-SNAPSHOT in JFrog was cached in the local repository, resolution will not be reattempted until the update interval of openhab-snapshot has elapsed or updates are forced

Snapshot versions are only available for the latest version, since a snapshot version changes with every change. Therefore theoretically it’s impossible to say what’s exactly in a specific snapshot version.

To build an older snapshot version you can compile the snapshot version using the release version of core. To do this, add -Dohc.version=3.2.0 to the maven command (This will work unless some breaking change with core is already in your local branch)

Thank you @hilbrand . I tried that your suggestion it generated the following error:

mvn clean install -Dohc.version=3.2.0

produced the following:

Failed to execute goal on project org.openhab.ui.reactor.bundles: Could not resolve dependencies for project org.openhab.ui.bundles:org.openhab.ui.reactor.bundles:pom:3.2.1-SNAPSHOT: Failed to collect dependencies at org.openhab.core.bom:org.openhab.core.bom.compile:pom:3.2.1-SNAPSHOT: Failed to read artifact descriptor for org.openhab.core.bom:org.openhab.core.bom.compile:pom:3.2.1-SNAPSHOT: Could not transfer artifact org.openhab.core.bom:org.openhab.core.bom.compile:pom:3.2.1-SNAPSHOT from/to openhab-snapshot (https://openhab.jfrog.io/openhab/libs-snapshot): openhab.jfrog.io: Unknown host openhab.jfrog.io → [Help 1]

I got it resolved by replacing all the Pom.xml version to 3.2.0 then everything is good.