[Solved] Unable to reconnect TKB10 thermostat

I was using TKB10 floor thermostat for some time (probably it was the only thing on the network that worked fine). I’ve experimented with other software and accidentaly hard reset the controller.
Now I am able to add TKB68 and Coolcam plugs but the TKB10 thermostat can not be added.
It displays wireless glyph, I press “Menu” button 3 times, it blinks a few second and nothing happens (of course the controller is in the inclusion mode).
According to the documentation the logo is displayed when the device is connected to the network.

Any ideas how I can re-include it?

Openhab 2.4 on RPi, z-wave.me stick, now installing latest and greatest binding

If you are sayint it cannot be added to the Z-Wave network on rhe controller, that is completely separate from OpenHAB.
I recommend factory resetting the thermostat and then trying to include again. Either that or try excluding & then including. The thermostat may think it should be talking to a different Z-Wave network.

Right, makes sense. Was able finally to exclude and re-include it by moving zwave usb dongle to a laptop with zensys tools.