[SOLVED] Unknown device for z water heatit - how to proceed?


I am a bit of new newb with openHAB so bear with me please.

I included a powered z-wave device. The device is a z water Heatit. I found it in the list of supported devices but have no clue on how to proceed with this.

The device is added as node 18 but it doesnt say much more in de web ui. Can anyone help me out or tell me how to proceed? I’d really like to use this device for heating my home. Thanks!

What version of openHAB?
Which of the 8 Heatit devices in our database?

For further assistance,

You need to have a Thing for your device, the Thing provides Channels (temperature, setpoint, …), the Channels need to be linked to Items.
Put the Items on your sitemap to set the temperature or to change the thermostat mode.
Please start reading the basic docs to get an understanding of how openHAB works.

@Bruce_Osborne Its the Heatit Z water. Picture is also exactly the same. Version is installed recently (like 5 days ago): openHAB 2.4.0 Release Build.

@sihui I get that I need to add it. I added other switches by adding items (fibaro plugs) and they work. The node 18 just doesnt have any channels. None at all because it shows up as unknown (I guess).

Here is your problem.
You need to upgrade your zwave binding to a recent 2.5 snapshot:


@sihui Because I am not sure about how to install this script inside a docker I updated the docker image to 2.5.0-snapshot:

openHAB 2.5.0 Build #1756

I don’t know if this has the same result as what you suggested but I hope its enough to do it this way? Else I could try to launch a bash shell inside the docker and try to run the script. Just let me know if its still needed.

The problem is now that the stick is showing as:

Status: OFFLINE - BRIDGE_OFFLINE Controller is offline

I found a post that suggested to install a powered usb hub in between but I didn’t have to do that for the older version I had so I don’t think that installing a powered usb hub would solve my issue. The stick is also plugged in into a Asus Vivobox installed with Debian buster and docker on top. The logs files on the local fs just show this:

2019-11-14 12:21:59.502 [thome.event.ExtensionEvent] - Extension ‘binding-zwave’ has been installed.
2019-11-14 12:22:45.945 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:ffdb12bb’ changed from UNINITIALIZED to INITIALIZING
2019-11-14 12:22:45.970 [me.event.ThingUpdatedEvent] - Thing ‘zwave:serial_zstick:ffdb12bb’ has been updated.
2019-11-14 12:22:45.985 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:ffdb12bb’ changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline

2019-11-14 12:21:18.334 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2019-11-14 12:21:23.024 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled ‘openhab-ui-dashboard’
2019-11-14 12:22:45.931 [INFO ] [zwave.handler.ZWaveControllerHandler] - Attempting to add listener when controller is null
2019-11-14 12:22:45.972 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port ‘/dev/zwave’
2019-11-14 12:22:45.998 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2019-11-14 12:22:46.009 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2019-11-14 12:22:46.009 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

Any clue?


Unfortunately I have no expertise with Docker, you need to wait for a user which is familiar with that.

Try deleting the Thing from OpenHAB and rediscovering. It should use the settings from the new binding.

If it is a battery operated device it may need to be woken up quite a few times to get completely discovered.

The device is the z-wave stick from Aeotec: https://aeotec.com/z-wave-usb-stick/

I can add it but it stays offline. Even after multiple removals/adding. I don’t think its related to docker because the only thing I updated (since the working condition) is the openhab version. Its plugged into the pc so I assume its not battery operated.

Edit: Off course no other z-wave switches, plugs or sensors are found.

Try shutdown OH, clear the contents of cache & tmp folders on userdata & restart. Next startup will take longer though.

I started with a completely new installation after it the stick didn’t come up right after updating. I just removed all config files (rm -Rf /home/openhab) and started a new docker instance.

But just in case I missed something I did it anyway. Same result.

Please provide a debug log so that we can see what is happening - it will help avoid a lot of guessing :slight_smile:

Yup, I was reading up on how to do it. I enabled with debug, removed the stick in the UI, stopped oh, emptied cache and tmp, started oh again and just added the stick. OH created a bit off logs:

-rw-r–r-- 1 openhab openhab 1.7M Nov 14 14:01 openhab.log
-rw-r–r-- 1 openhab openhab 17M Nov 14 14:00 openhab.log.1
-rw-r–r-- 1 openhab openhab 17M Nov 14 14:00 openhab.log.2
-rw-r–r-- 1 openhab openhab 17M Nov 14 14:00 openhab.log.3

You want to view everything? Do I upload those files to a google drive or something? Because thats quiet a lot of files :slight_smile:

Just interested in openhab.log. The rest are older copies.

Yes please.

@Bruce_Osborne No this is a fresh install :slight_smile:
@chris Will do and provide you a link in a min.

1 Like

Hmmm - not really. Probably the openhab.log is the least interesting. The first one will probably be the most interesting (probably openhab.log.1) as it will contain all the startup information. The most recent one (ie openhab.log) will likely be after the initialisation is complete.

1 Like

@chris all four logs tarred and zipped: https://drive.google.com/file/d/12DxYaLPrW5t2SCWsLpg9PtWV60OMIK-g/view?usp=sharing

Thanks in advance!

To be honest, I’m not sure what is in these logs… I think that it is logging a bunch of stuff while downloading the bindings (ie lots of http ‘noise’), so there is no actual useful information from the bindings in these logs.

I’d suggest to only enable debug logging for the zwave binding - keep everything else at the default (info or warn - I forget which, and it doesn’t matter really). This will keep the noise down, but I suspect that you need to wait until the binding is running - possibly not clearing the cache might help as well as I think that might be what is being logged in these files.

1 Like

Here it mentions how to get OH to separate out the zwave logs.

1 Like