[SOLVED] Upgrade to 2.4 and now getting temperature in wrong units


I just upgraded from openhab 2.3 to the M5 snapshot of 2.4. All went well, except that it now appears one of my zwave devices (and only one) is reporting temperature in fahrenheit when all the others are reporting in celsius.

The device is a PST02B Slim Multi-Sensor (PIR/Temp/Illumination). I’m mapping the channel to an item using a line like:

Number Sensor_Temperature “Temperature [%.1f °C]” (Temperatures) { channel=“zwave:device:long_id:node10:sensor_temperature” }

This was working fine in my 2.3 build and producing sensible numbers in celsius (e.g. 23 deg C), but now I’m getting values like 72.

I’m still a bit of a beginner with openhab, so not sure if I’m doing something wrong here, but the fact it worked in 2.3 and doesn’t in 2.4, and yet all my other zwave temperature sensors work fine indicate a problem. Note: all my other temperature sensors are from different devices/models, so could it be a misconfiguration for this particular model?


Gargh never mind. I had to change it to:

Number:Temperature Sensor_Temperature “Temperature [%.1f °C]” (Temperatures) { channel=“zwave:device:long_id:node10:sensor_temperature” }

I had actually tried this but was getting no value back which I figured was an error but it was actually just because OpenHAB must erase the old value and wait for a new one (which takes a while sometimes)!