[SOLVED] Vemmio Z-Wave (030F:0001:0001:1.8) Unknown

Hi, I recently purchased the Vemmio double switch, MODEL: DS-100 V1.0

Z-Wave Node 12 (030F:0001:0001:1.8)
Unknown Device

Has this yet to be added to the DB?

Yes - it’s not in the database. You can find information on adding devices at this link -:



I tried to follow the instructions, but I don’t have a folder called /etc/userdata is this out of date? Where can I find the xml file for the uknown thing?

OK I think I found it:


It seems your manual needs updating.

The userdata folder may be mapped to many different places depending on what OS you are using. I know in the instructions for openhabian it says where it’s mapped to - I can’t list every (or really any) installation that might be out there.

Hi, Sorry I didn’t realise it would depend on the system. I’m using a Raspberry Pi. I’m still learning. I started to add the double switch to the DB. I haven’t had time to add all the parameters yet. I’m also not sure about what to put in the mask. There is nothing about a mask in the manual for the switch. I’ve left them blank for now. I will try to add the rest of the parameters tonight.

Don’t worry about the mask - this is a OH special feature and it allows us to break out different parts of a ZWave parameter to treat is separately (eg we might have 3 colours in a single value - this allows us to split them and present them to the user as 3 values rather than having to have the user work out the numbers).


I’ve added all the parameters, but I’m a bit confused about what goes in the end-points. it’s not clear to me. Can you help a little?

You shouldn’t have to touch the endpoints - this is filled in automcatically when you upload the XML file…

ok cool. In that case it should be good to go… at least good to try.

let me know when you have made a new snapshot.




Does the latest snapshot contain this new swtich? I’d like to give it a go.



Yes, it should be there - unless you’re telling me it doesn’t?

I haven’t tried yet. Was waiting for your goahead. I’ll give it a go and let you know.



So I gave it a go. Initially when it is discovered in the inbox, it shows up as uknown. However, if you proceed to add it, it seems to work fine. I’ve tested both switch 1 and switch 2. I’m able to turn them on and off independently, or together from a third end point.


This is perfectly normal - ZWave devices always get added as unknown first, then once all the information is available to complete discovery, it gets updated. For mains powered devices, this usually happens fast enough that you probably don’t notice (although this will depend on what is happening on the network), but for battery devices it will normally take some time.

ok great, understood. Current readings are coming up now. I just had to wait a bit.