[SOLVED] Weatherflow Smart Weather Station binding

Hello @hww3

Getting this error with Oh4.1Milestone 5

 - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.weatherflowsmartweather-4.0.1.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.weathercalculations [28]
  Unresolved requirement: Import-Package: org.openhab.core.config.core

can you compile it new?

It’s actually surprisingly hard to make versions for a particular milestone release. I think the 4.1 release is almost here, so I’ve prepared a version for that:

http://bill.welliver.org/dist/openhab/org.openhab.binding.weatherflowsmartweather-4.1.0.jar

Hello is there a trigger available for the rain event?

I mean is this API

Rain Start Event

Also implemented?

There is a rule trigger that exposes this, along with the lightning strike event. You just have to create a new rule and use “when rain started” and choose the correct smart weather device.

I’ve been told that the trigger works, but I’m not sure I’ve ever seen it (I have an older sky device, so there may be a difference in behavior).

Thanks for this great binding, Bill! Using it for almost 2 years (since the early days :slight_smile: and it works like a charm.

Just upgraded to OH 4.1 and installed your recompiled version 4.1.0. Initially I thought it was broken as no channels received any updates for a couple of minutes despite log files showed that hub was auto discovered.

After a full OH restart and a couple of minutes of patience the channels finally updated.

Just wanted to thank you for your work on this binding: THANKS!

1 Like

Hey Bill,

Thanks for the binding and aldo thank you for updating the binding quickly to the next version.

Is there a reason why you don’t put it into the official repo? Because this helps to cool down your time if a new milestone or version is coming up?

2 Likes

Hello,
I have a general issue getting the humidity from my weather station.
All other channels work perfectly, and also in the past (I think with OH3) it was working.
Here a screen shot of my humidity channel


Any idea why explicitly this channel is not working?
Here also my item definition:
Number:Dimensionless SmartWeatherHub_Humidity “Feuchte [%.1f %% rH]” (Group_Weatherstation)
{ channel=“weatherflowsmartweather:tempest:HB-00041084:ST-00023261:humidity” }

I’m not sure why that particular item is not updating. Can you try creating a new item linked to that channel using the UI? I’m not very familiar with how items in config files get linked.

Hello Bill,
I linked now via the UI → it lokks like there are some values, but now in a different format.
Anyhow, my manual linking goes to the sane channel

Here the UI:

Any ideas why this is now different?

Update, it looks like, the linked item via the UI is working,
→ thanks for the hint.

Strange: This is the only channel which is not working as defined in the configuration file.
even it uses the same channel …

The humidity value also (sometimes) formats oddly for me; I haven’t found a good solution to the problem (though as a workaround you can supply formatting metadata to the item to get it to look better).

Beyond that, I’m not sure why you were having problems with items linked to that channel not updating specifically… there isn’t anything special about it compared to any of the others. I have found more generally that openhab sometimes gets confused internally and that recreating items will solve the problem.

Please do let me know if you have any questions or problems!

I can only suggest to have a look at this thread: OH 3 to OH 4 : most percentage values are now divided by 100

To sum up, for the foreseeable future, you MUST edit your items to set their unit to “%” instead of “one”.

1 Like

Hello obones,

thanks for the hint.
I could not find a setting for unit to set to %


maybe I missed something?

Hello Bill,

thanks again for the help.
It works now so no further topics open.
In case the manual linked channel is working again, I will let you know

1 Like

It’s on the page before, where you can add Metadata:

There you can choose the Unit metadata and set it to %

Hi All-

I’ve not yet started to upgrade my setup to 4.2, but for those who have, I’ve recompiled the weather flow binding for 4.2. I haven’t done any testing, and you may find that the version you’re running works fine… there don’t seem to have been any API changes that impact the binding, but dependency changes in the new version can cause older versions to stop working. If that’s the case for you, try installing this new version (after removing the old one, of course!). As aways, do let me know if you run into any difficulties!

http://bill.welliver.org/dist/openhab/org.openhab.binding.weatherflowsmartweather-4.2.0.jar