[SOLVED] WeMo Switch - OFF-ON-OFF-ON not OFF-ON?!

My WeMo gets detected reliably and switches on and off reliably. I can control it programatically with rules with no problem. I set it up through PaperUI. In troubleshooting I have completely deleted it through the console and started again with the same issues.

The problem is that I noticed in the logs that it does not do a simple OFF-ON. It goes OFF-ON-OFF-ON and you actually see the switch moving through this cycle in the interface. (See log file below). When I switch the Switch with the WeMo app it works as expected.

This mostly causes me few issues, but it does make the system respond to an OFF event I set up when I turn the machine ON. Has anyone else seen this? Does anyone have a suggestion as to how my

  Item CoffeeMachine_Switch changed from ON to OFF

rule can ignore an OFF-ON-OFF-ON event?

2019-09-11 10:14:59.065 [ome.event.ItemCommandEvent] - Item 'CoffeeMachine_Switch' received command ON
2019-09-11 10:14:59.080 [nt.ItemStatePredictedEvent] - CoffeeMachine_Switch predicted to become ON
2019-09-11 10:14:59.107 [vent.ItemStateChangedEvent] - CoffeeMachine_Switch changed from OFF to ON
2019-09-11 10:14:59.209 [vent.ItemStateChangedEvent] - CoffeeMachine_Switch changed from ON to OFF
2019-09-11 10:14:59.788 [vent.ItemStateChangedEvent] - CoffeeMachine_Switch changed from OFF to ON

What binding?
I believe some bindings send the command and then try to verify the status of the Item.

The ‘predicted’ comes from openHABs autoupdate feature. This is enabled by default, and can be disabled per individual Item.
It listens for commands to that Item and has a guess/prediction about the likely outcome, then updates the Item state accordingly.
This is to give a responsive UI when the actual change at the device is going to take some time, or maybe never gets reported back to OH at all.

A short time later, probably in response to being sent a command, the device or an intervening bridge has reported that it is still OFF for now. Unfortunately that overwrites autoupdate’s earlier work.

Half a second after that, the device reports “Yep, I’'m ON now”

If you disable autoupdate on your Item, it will remove the dithering. But your UI will take a second to pick up the change. That’s probably less annoying than dithering?

1 Like

WeMo Binding by Hans-Jörg Merk

Are there others?

Thanks - very interesting, I had no idea of that setting and its effect.

It has fixed it immediately and I am delighted!

Thank you so much. :smiley:

Yes, I have some switches on Z-Wave.
Some use Zigbee. I believe there are some Wi-Fi switches

EDIT: Sorry, I somehow missed WeMo in the thread title. I will blame lack of morning coffee. :coffee::coffee:

1 Like