[solved] Wrong TZ config, errors on startup

I probably made a mistake and configured a Time Zone in Paper UI - Configuration - System
Now I have a huge number of errors on startup, the most relevant seems to be this one:

[ERROR] [org.eclipse.smarthome.core ] - [org.eclipse.smarthome.core.internal.i18n.I18nProviderImpl(50)] The activate method has thrown an exception java.lang.ClassCastException: java.lang.String cannot be cast to java.time.ZoneId

I cannot revert the change through Paper UI. Any other option? Karaf console?

Which version of OH are you running? @Benjy and @DanielMalmgren, this might be related to the problem on your thread.

1 Like

openHAB 2.2.0 Build #1063

Can confirm this to be the case on a blank install. I’ll post a report on Eclipse Smarthome.

1 Like

I can confirm it.
After the upgrade to 1063 I get the same messages.
Unfortunately I do not come back to a stable version.
Is there a way / trick, how I get back into a stable assignment?
I use openhabian and have already tried over the config to change STABLE 2.1, unfortunately without success.

Ftr, issue is tracked as https://github.com/eclipse/smarthome/issues/4426.

1 Like

For those who need to have openHAB running again (@The-Elk, @AndrewZ) you may revert the change and delete the single line containing:


in $OPENHAB_USERDATA/config/org/eclipse/smarthome/core/i18nprovider.config


@Benjy and @Kai

I deleted the single line containing:




and after a reboot, openhab also works again.

Thank you so much and good night :wink:

1 Like

Yep, seems to be the same that hit me. Just for the record though, I was on 2.1 stable. Is it a strange coincidence that nobody has seen this until now and then suddenly two users with completely different versions encounter it at the same day?

That solves the problem, thanks!
Initially I tried to solve this on my own, I found that file and deleted just [something], that was obviously not enough.

The problem is fixed in the latest distro 1064 - no need to do workarounds anymore!