[SOLVED] Z-Wave database needs update. Unsure from what FW version

The Fibaro FGRGBW RGBW Controller with FW v25.25 now supports parameter values that are not accepted with the current database.

Param 44 & 45 now supports value 0 for turning off reports.
This is of interest in large networks were one wants to eliminate unwanted traffic.

This is the Attributes of my device, purchased about 6 months ago.


Please advice how to handle this.
I do not know in what FW this was introduced.

The minimum in the database for parameter 44 and 45 was set to 1 instead of 0. I have changed this so in the next 2.5 zwave snapshot (after the database changes got merged into the binding) you should be able to upgrade and use 0.


@sihui, thank you!
So you guess it is OK to do it for all FW versions even though the earlier ones might not support the 0 setting?

Why would you do this? It doesn’t make sense to me to provide a setting that is incorrect, but maybe I miss something?

Because my new device supports the 0 values to shut up reporting. Older devices might not.
They have the same Type/ID, but (I would guess) different firmware versions.
I only own the new type and the current data base limits wouldn’t allow the 0 setting through.

Maybe I misinterpreted your question. I thought that you were updating multiple database entries for different firmware versions? If there is only 1 database entry, then this is fine - if there are multiple entries, then it is not such a good idea.

Currently only one, but valid for ‘All FW versions’
This is where I’m unsure, If you can/will/prefer differentiate on FW versions, just loosen up the limits or make a new entry.

Ok, understood. I think this is ok - it should not cause any problem, although maybe some minor confusion if people want to set this.

If this is the only change in the firmware, then it’s probably not worth creating a separate database entry.

All Fibaro manuals do list 0 as a valid parameter, starting with firmware version 2.1. Of course I checked that before making any changes :grinning:


1 Like

Of course! Pardon the confusion …
I’m glad I’ll able to shut the reporting up soon :slight_smile:

Thanks again.

1 Like

Now possible to set 0 for param44 & 45 (2.5.0-SNAPSHOT Build #1482)

Thanks @sihui

1 Like