[SOLVED] Z-Wave devices remain unknown after update

zwave
Tags: #<Tag:0x00007f51e41e4870>

(Sven) #21

Hi there I followed the tips here but I still not able to use my fibaro dimmer 2 anymore. All devices came up properly after a few hours, but the dimmer are stayed unknown, after updating to 2.5.

Before (i think it was 2.2) everything was working smoothly and than I updated to 2.5, went though the update tutorial to get all zwave device back in, but it diddn´t worked for the dimmers.
I tried soft reset via UI and also unplug the device.
put the dimmer in inclusion mode,several reboots etc…

I´m running openhabian on Pi and now also updated to the latest snapshot (before I tryed stable).
My zwave usb stick is the ZMEEUZB1 which is directly conntected to the pi.

If you have any suggestion, I would be more than happy to use my lights again :slight_smile:

openhab.log (806.8 KB)


(SiHui) #22

Are you sure you deleted the “Thing” and readded it again? I only have one of the Fibaro Dimmer 2, but it is working without any problems in 2.5 snapshot.


(Sven) #23

After the update, none of my zwave device were going online, so I deleted all and uninstalled the zwave serial controller and reinstalled it again.

All other ZWave items came back and I needed to add them again.
All except the Dimmer. They still show unkown device.
From my understanding the “Thing” insn´t installed in oh yet, since it poping up in the inbox.


(SiHui) #24

Are you sure it is in range of the controller?

Here is one of your FGR222 devices, it shows that the node info was received by the controller.

Here is your dimmer, the controller does not receive the node info:


(Sven) #25

The dimmers are at a distance of about 3-10m from the zwave dongle without any walls in between. Other devices on other floors much further away are working without any problem. Even now after a week the devices are still on same state.^

When I add the Thing i get following response.


(SiHui) #26

You are on the right track: providing a debug log. BUT: please post it as text, please use code fences, please don’t filter the log.


(Sven) #27

np, I thought those messages would be enough.
Here is the current log. node 18 is one of the items.

openhab.log (705.0 KB)


(Ian) #28

Node 18 doesn’t seem to appear in the log? I ran it through the log viewer:

https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer

Node 18 does not show up.


(Sven) #29

I added node 18, maybe thats why it doesnt show up?
but the nodes 12, 22, 26 are sharing the same issue.
I also tried resetting one of the dimmer by holding the button for 3 secs without any difference…

Before the update everything worked perfectly, tomorrow I´ll try to downgrade? Current OH release isn´t usable for me at this stage.


(Sven) #30

Would it work to just downgrade the Z-Wave binding to see if devices will work again or do I need to downgrade openhab as well?


(Sven) #31

I think I got it working now, but I can´t tell really what did the trick.
In Chrome I got often no response or hanging paper and habmin ui.
In Firefox I tried set device as failed, which gave me the massage that the device could not be found and now its showing the dimmer. Very weird thing but at least it´s working now

From now on I will only use Firefox with OH…


(Mats) #32

Hi! I am suffering the same fate. After updating a couple of days ago, some of my devices (especially the Fibaro switches, it appears) are turning up “Unknown device” in the Inbox, and when adding they appear Online - but no good.

Among other things - the logs says:
“Device discovery could not resolve to a thingType! Manufacturer data not known.”

My specs:

  • Raspberry Pi 3 Model B Plus Rev 1.3
  • OpenHAB 2.4.0-1 (Release build)
  • Aeotec Gen5 z-wave USB stick

One of the Fibaro devices in question is the Fibaro Single Switch 2 FGR213, I have noticed that these devices are frequently mentioned when it comes to “Unknown devices”.

Versions:
openhab> bundle:list |grep -i zwave
191 │ Active │ 80 │ 2.5.0.201902110612 │ ZWave Binding
openhab> bundle:list |grep -i openhab
180 │ Active │ 90 │ 2.4.0 │ openHAB Core
181 │ Active │ 80 │ 2.4.0 │ openHAB Karaf Integration
183 │ Resolved │ 80 │ 2.4.0 │ openHAB Sound Support, Hosts: 116
184 │ Active │ 80 │ 2.4.0 │ openHAB Dashboard UI
197 │ Active │ 80 │ 2.4.0 │ openHAB 1.x Compatibility Layer
228 │ Active │ 80 │ 1.13.0 │ openHAB Prowl Action
229 │ Active │ 80 │ 1.13.0 │ openHAB Expire Binding
230 │ Active │ 80 │ 1.13.0 │ openHAB HTTP Binding
232 │ Active │ 80 │ 1.13.0 │ openHAB Weather Binding
233 │ Active │ 80 │ 2.4.0 │ openHAB REST Documentation
234 │ Active │ 80 │ 1.13.0 │ openHAB InfluxDB Persistence bundle
235 │ Resolved │ 75 │ 2.4.0 │ openHAB Basic UI Fragment, Hosts: 225
236 │ Resolved │ 75 │ 2.4.0 │ openHAB Classic UI Fragment, Hosts: 226
239 │ Resolved │ 75 │ 2.4.0 │ openHAB Paper UI Theme Fragment, Hosts: 227

So what did I do?

  • Installed the OH2.4
  • Removed all devices except stick, installed the Z-wave binding (not snapshot) from PaperUI, and searched for new devices.
  • Found devices where “Unknown device”.
  • Waited several hours to see if something happened, no go.
  • Tested removal several times.
  • Tested shutdown and restart.
  • Tested excluding and including devices with USB stick solo (not connected to RaspPi) and in close proximity.
  • Clearing /tmp and /cache
  • Removed Z-wave binding, installed 2.5-snapshot - and gnu.io manually - afterwards repeating all the above mentioned testing, still no go.
  • Tested soft reset, by disconnecting the stick, pressing reset button once, and connecting it again. Tried this three times.
  • And using Firefox did not seem to have any impact…

Seems to me that I get a lot of the (failing) results that is mentioned in this thread. Same kind of values in the properties of the Thing.

Including a couple of logs from my latest boot.
20190217-events.log (22.4 KB)
20190217-4-openhab.log (890.4 KB)
20190217-3-openhab.log (798.2 KB)
20190217-2-openhab.log (875.4 KB)
20190217-openhab.log (482.4 KB)

For some reason there are several nodes 7,9 and 14,15 appearing as “Unknown devices”. But I just added 14 and 15 and left the others in the inbox. 14 and 15 are “Online” but of no use.

UPDATE: I added 7 and 9 also. 9 was recognised. Node 7 entered a state of “OFFLINE - COMMUNICATION_ERROR”. It is also strange having now three devices (7, 14, 15), as I only have two devices not communicating. Maybe 7 is some old stuff hanging around?

Really appreciate any help! :smiley:


(SiHui) #33

You are getting huge timeouts from node 7:

grafik

Try removing it from the controller, set it as failed, then click remove (advanced thing menu in HABmin).


(John Riker) #34

I’m having similar problems with a Leviton dimmer plug in switch. If I move it real close to the unit it seems to sync up. Enough to get the channels in OpenHAB. Then when I move it to it’s destination and heal it’s there, but eventually gives a communication error. Funny thing it is slow but still responds to commands. So not sure if it’s a distance thing or what. Just sharing other device types are having this issue as well. On the same OH version and using the latest snapshot as of yesterday.

As a side note, if I try and change the Command Poll Period from 1500 to like 3000 which some say helps the communication error, it won’t stay. Looks like I can only “select” 1500 or Disabled.

JR