[SOLVED] [Z-Wave] OH2.4.0.S1443 - No temp values from Spirit Thermostat

Sorry for giving less information:

my system in win10x64 with zulu jave latest 8-version. OH snapshot 1443.

The config is not changed and the same as working in OH2.3. All other parameters from the device I get, only temperatur is missing.


Number RadiatorThermostat01_Temperature         "Computerzimmer Heizkoerper Temperatur [%.1f °C]"       (gMAPDB,gRRD4J){ channel="zwave:device:15a7a49f3a6:node76:sensor_temperature"}

Screenshot from habmin, the temperatur value was restored from mapdb not a real value from binding! Maybe misleading:

1 Like

I would try the following:
Delete the Thing from PaperUI
delete the corresponding xml from userdata/zwave for this node
rediscover it from PaperUI (no need to exclude it and re-include it from the stick)
wake up the device to get it to be properly recognized by the binding
double check Item links to the proper channels

does your OH2 console spit the same info as me? (also on S1443 with Z-Wave but I don’t have this Thermostat)

openhab> bundle:list -s |grep zwave
240 x Active   x  80 x     x org.openhab.binding.zwave

some background information to @Dim suggestions:

1 Like

I know the 2.4 effect. I solved all my other related thigns. Only two devices are left which are not working correct after migration from z-wave 2.3 to 2.4.

Yes, my version of z-wave binding is the same.
And I tried this 3 times with no effect.

… and make sure you have spaces where spaces are needed:

Number RadiatorThermostat01_Temperature "Computerzimmer Heizkoerper Temperatur [%.1f °C]" (gMAPDB,gRRD4J) { channel="zwave:device:15a7a49f3a6:node76:sensor_temperature" }

There is one missing between your group definition and your channel definition. And don’t tell us in your actual setup the space is not missing because of a copy and paste error :rage: :grinning:

1 Like

yellow or red card? :slight_smile:
Good catch @sihui
I would bet 5€ that this is the problem :stuck_out_tongue:
Mr. Home Automation is in a hurry :blush:

edit: VSC doesn’t not scream about not having a space… I will lose this bet :smile:

1 Like

You are right, there are no spaces, but in no of my other items there is a space, and all others are working fine. I will try it.

This does the trick, thanks a lot!

But I not really understand it. Only this item in affected by the missing spaces. All my others are working fine :wink: But good to know this.

1 Like

Now that I know the trick I will reactivate this topic too

Maybe it is the same root cause.

Yepp, I checked that too, not any complaints in VSC, sadly.

1 Like

Sorry, I must reverse what I said, problem is not solved. I misinterpreted my log. I have to similar looking items and mixed them, sorry for that, problem still there

How to unmark the solved?

I updated the thread title
In theory, you should be able to uncheck the solved mark…

Have you checked the configuration parameters of your Spirit?

1 Like

Yes it is 5. As before in OH2.3.
I made a screenshot of every setting before migrated to OH2.4 snapshot. For some devices I had to re-adjust the settings but for the radiator thermostat all was and is correct.

Could there be something wrong with the association settings?

I will buy a second one and try if there is something wrong with this one.

Is this the solved mark you mean?

post #8

Before you buy a new Spirit I would try a reset.
Exclusion, take the batteries out for about 5 minutes and then inclusion.

1 Like

I bought a new one and this one is working correct now. I then took off the battery of the old one wait 5 min. and then pluged them in again. The old one is working too now again.

Just a problem with the device, not of the binding and not the missing spaces :wink:


good stuff man! :+1:

adding to the title [Solved] ! :slight_smile: