[SOLVED] Z-wave Removing device completely

A little history…
I had an Iris by Lowes system but since they are discontinuing it, I’ve decided to go with a Raspberry Pi and openHAB. I bought a Z-wave USB stick and got all of my dimmer switches working with no problem. Then I tried pairing the smart plugs and found out those aren’t Z-wave but Zigbee so I got a Z-wave/Zigbee combo USB stick.

Now the problem, I cannot get the dimmer switches to pair with the new combo stick and I’m almost positive it’s because they are still paired with the Z-wave stick. I plugged it into my desktop computer and installed openHAB, when I go to the inbox, the dimmers are there. I go to Configurations -> Things and hit the trashcan which removes them. However, without putting the switches in discovery mode, when I go back to the inbox, press the plus sign, Z-wave binding, those switches immediately pop back up. This makes me think the trashcan is not removing the devices. Am I right? If I am, how would I remove them so I can add them to the new stick?

Thanks in advance!

You need to exclude the device from the ZWave network so that it is removed from the stick, and can be added to the other stick.

In the ZWave controller, there is a configuration parameter called something like “Enable Exclusion”. It’s an advanced parameter, so you need to enable advanced mode to see it. Enable this, then click whatever button is required on the device to exclude it.

This should remove it from the current stick, which will stop it re-appearing in the inbox with the binding starts, and will also allow you new stick to include it.

Well that was simple enough! I didn’t understand what exclusion mode meant, now I do. Just means remove device. Thank you for the help!

I edited your title to include Z-wave and Solved. If you would please click the square box on the post that provided the solution. This will help others with a similar issue find a quick solution.


Sorry to revive this, but I dont see a config parameter called “enable exclusion”. Was this a change with the release of 3.0? When I click on “Exclude Devices” I get a dialog box and click Ok. Then press and release the button on my GE outlet and nothing happens. Really no explicit feedback telling me if this worked or failed. Also, there is nothing in the /var/log/openhab/openhab.log either.