[SOLVED] Zigbee Startup issues with Binding

Tags: #<Tag:0x00007f2fbe4ddbf0>

Hey all…new user here.

I am adding a Nortek HUSBZB-1 Stick to my Windows based openHAB installation in an attempt to experiment with Zigbee.

I have followed the instruction on previous posts and installed the Windows Driver and successfully have the device recognized in Windows as COM4.

I entered this in my .things file:

Thing zigbee:coordinator_ember:stick “Zigbee USB Stick” [zigbee_port=“COM4”, zigbee_baud=57600, zigbee_flowcontrol=2, zigbee_childtimeout=864000, zigbee_concentrator=1, zigbee_meshupdateperiod=86400, zigbee_panid=35637, zigbee_extendedpanid=“118E309DE90CC829”, zigbee_networkkey=“14 c6 a2 c7 fb e0 c3 19 8e 7c 36 30 dc ad a5 96”, zigbee_powermode=1, zigbee_txpower=8]

When it shows up in PaperUI it shows as “Offline”. I assume it is because I need to replace the word “stick” in my thing definition with an 8 digit number representing my sticks id? If that is true, then how do I retrieve this number from my stick or my windows environment?

Cam

That stick is both Z-Wave and Zigbee. With the proper drivers it shows up as 2 COM ports on Windows. One for each protocol.
If you only see it as one port something is wrong.

Please read the documentation. Using a manual Thing is not the correct or supported method. The preferred methods is to use HABmin to add the stick to OpenHAB.

No - that’s incorrect. The word stick is fine - this is just a number/name that uniquely identifies a thing (it’s just part of the UID).

1 Like

I am not interested in the ZWave portion at this point because I already have a functioning Z stick. It does show as unique COM ports for each the ZWave and zigbee, I was just trying to use the Zigbee only and I read on the binding documents that for Zigbee, you have to define your “thing”, unlike the ZWave binding.

I see, thanks…I won’t waste any more time on that, I’ll dig deeper into other communication settings … thought I had them all good but I must have missed something.

Cheers

Cam

OK, I have not st up Zigbee on mine. I am currently using Linux but the process should be the same, from an OH perspective.

No - it’s the same as the ZWave binding - or in fact any binding. You can either define the thing using textual definitions, or simply through the UI.

1 Like

I see, but does your zigbee binding auto-discover the “Serial Zigbee Controller” just like your ZWave binding auto-discovered the “Serial Z-Wave controller”…maybe the word Auto discover is the wrong word but I am sure you know what I mean. It just needs me to properly specific the communication parameters?

If so then maybe I should just uninstall the Zigbee Binding and then reinstall it as a good way for me to start over?

Cam

The ZWave binding doesn’t discover the Zwave controller. Depending on the ZigBee stick, the ZigBee binding might as it has implemented the autodiscovery via the USB service on some computers (ie Linux only from memory). This is not implemented on the current ZWave binding as it caused all sorts of problems with opening serial ports and was removed a long time ago.

2 Likes

Copy that. Thanks for the replies. I must have missed something else, but I have thought of a few things I can try on my second attempt.

Cam

Okay…don’t i feel silly. Tried again the easy way by using your binding and it worked right away!

Thanks!

Cam

2 Likes

I got the binding working and “Online”, was able to factory reset my test devices and get the devices partially paired to the usb stick…the device specifically is a Control4 c4-TV120277 0-10V dimmer. I’d attach the manual, but I am still a new user and can’t just yet I suppose.

I have read about your zwave binding and have seen how to check for device compatibility in the database, however, I haven’t found a similar way to check for device compatibility of the Zigbee binding.

Is there such a database and is there a way for me to check the compatibility of these devices at this time?

Once again:
Device = Control4 c4-tv120277 dimmer
Controller = Nortek HusBZB Ember controller
OS = Windows based openHAB 2.5 Snapshot.

Device was discovered and in inbox but says it’s offline, it is an “unknown zigbee device” and that “Node has not completed discovery.”

Cam

Link to the manual:

The ZWave database is totally different - it is there to create the thing definitions. Therefore, an entry for the device must be added to the database before the device can be used. The ZigBee binding dynamically creates things based on an interrogation of the device and there is no thing definition required.

There is a list of compatible devices in the binding documentation, however as always this relies on people updating the list, which normally isn’t something they bother to do :frowning:

I understand your frustration with people not updating…

So then if I understand what you are saying…my device should be compatible and that there is possibly another problem on my system…which I should be able to resolve without having any database or binding code modified?

I still suspect that I still have some issue on the controller and I’ll research and study the logs. I just wanted to make sure that this device would be compatible before I try and fix something that I wouldn’t be able to.

1 Like

I can’t of course be sure, but the way the binding works is to read information from the device to discover its features. If the binding find features in the device that the binding supports, then it automatically provides a channel for this.

We have a lot of different channels, but not every feature of every ZigBee device is supported, and if a device doesn’t implement the standard ZCL features, then of course it won’t be supported.

A dimmer should, in general be supported, but I can’t tell what is actually implemented on your device - a debug log during the interrogation would help to understand this.

1 Like

Thank you so much for your input and explanation. I’ll get to work and if it works I’ll let you know and then figure out how to update the list of working items! :wink:

Cheers

1 Like