[SOLVED] Zipato Keypad Mini Alarm(Burglar) does not update the item

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Rev 1.2
    • OS: Raspbian GNU/Linux 9 (stretch)
    • openHAB version: 2.4.0 - Release Build

I bought a Zipato Keypad Mini and included it successfull in the z-wave network. The Thing has four possible channels

  • Switch - Switch
  • Alarm (burglar) - Switch
  • Alarm (access) - Number
  • Batterieladung - Number

The “Switch” channel is not mapped to an item. The “Alarm (access)” channel is mapped to an item and works fine. The channels of “Alarm (burglar)” and “Batterieladung” are mapped to items but do not update the item.
I added the controller as Association Group for that Thing, but in the Z-Wave Network Viewer the node is displayed with red edges:

What do the red edges mean?

I opened the case and pressed the tamper button. When I leave the tamper button I get a new entry in the logs:

[me.event.ThingUpdatedEvent] - Thing ‘zwave:device:691489f2:node27’ has been updated.

So I decided to press the tamper button again, start a debug log and leave the tamper button. The produced log file is here: log.txt.txt (11.5 KB)

Could anyone help me and get the channels “Alarm (burglar)” and “Batterieladung” working?

Best regards

I fixed it with the following steps:

  1. shutdown my raspberry
  2. unplug my Aeon Labs Z-Stick Gen 5 while raspberry it not powered on
  3. plug in the stick
  4. power on the raspberry
  5. reset the association group in the thing configuration
  6. Wakeup the Zipato Keypad Mini several times
  7. Heal the network
  8. reboot the raspberry

maybe some steps are not relevant

These are the only steps that should be necessary. Although, a soft reset (power cycle) can help with some things too. After restarting OH, you may also need to wakeup the device to complete initialization before being able to set the association. It should go into the queue though, but may need several wakeups to get it all done.

1 Like