[SOLVED]Zwave controller issue after upgrading to 2.3.0

zwave
Tags: #<Tag:0x00007f51e0a61f38>

(Ben) #1

Hi,
just upgraded my system to 2.3.0 stable through the openhabian config tool. Then the z-wave serial controller immediatelly went offline with an error, that the port ttyAMAO doesn’t exist.

2018-05-28 17:35:12.020 [hingStatusInfoChangedEvent] - 'zwave:serial_zstick:5668fa7e' changed from INITIALIZING to OFFLINE (BRIDGE_OFFLINE): Controller is offline

==> /var/log/openhab2/openhab.log <==

2018-05-28 17:35:12.037 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyAMA0'

==> /var/log/openhab2/events.log <==

2018-05-28 17:35:12.051 [hingStatusInfoChangedEvent] - 'zwave:serial_zstick:5668fa7e' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): Serial Error: Port /dev/ttyAMA0 does not exist.

What could be the problem in this case? There is no possibilty of choosing the port again, habmin as well as paper ui only offers me the ttySO port which is not working. I didn’t change anything, besides doing that upgrade.


(Chris Jackson) #2

The normal reason is down to security access. I’m guessing that upgrading the OS might have changed some security settings and hidden the port. Have a read through the installation docs as I think there’s information there about configuring the port security.


(Ben) #3

Cannot find anything there about the port security. I have reset all the port permissions through the menu in openhabian-config without success. Where can I set the security options for my ports?


(Chris Jackson) #4

Try this -:

https://www.openhab.org/docs/installation/linux.html#privileges-for-common-peripherals


(Ben) #5

Thanks chris; Couldn’t solve the issue with following the steps in your link, but removing the ports in openhabian-config and resetting them could somehow solve the issue.


(Rob Kamp) #6

See this thread: https://community.openhab.org/t/solved-how-to-define-a-serial-port-on-raspberry-for-openhab2-for-my-razberry-zwave-binding/6693/5?u=robjkamp