[SOLVED] [ZWAVE] Lumi switch LM-SxZW showing as Unknown Device

Tags: #<Tag:0x00007f4348591b58> #<Tag:0x00007f4348591a90> #<Tag:0x00007f43485919c8>

It may work OK assuming we have the the correct device & type entered. We got that information from your xml file.
I think the switch will just ignore unneeded items. I have a sensor where OH defines a temperature senor that does not exist on my model. My sensor just ignores that and works fine.
I added the association groups and requested review.

Cool. I hope it works.
The IT guy at the store said that, as far as he knows, the manual should be relevant for both switch types.
Honestly, I’m not convinced he actually knows what he’s saying, but once the binding is configured I will test and we will know for sure :slight_smile:

When should I test again?

1 Like

@chris @Bruce_Osborne

I have a second problem I could use your assistance with. I’ll ask it here, but if you say it merits opening a new topic I will open a separate one.

As I said before, I bought two Lumi switcher types for my apartment.

  1. switch with 2 lights + 2 blinds buttons.
  2. switch with 4 lights on/off buttons.

In this topic so far, we discussed the first switch (2+2), but I also need to configure the second 4lights switcher.
The problem I’m facing is that the Zwave Binding for OpenHAB doesn’t recognize the 4lights switch as a node when I put it in Inclusion mode. It just doesn’t show up, so I can’t pair it with OpenHAB.

In order to negate the possibility of a faulty switcher box, I tried to add the 4lights switcher as a node in Domoticz. And, unlike OpenHAB, Domoticz was able to recognize the 4lights Switcher as a usable node.

Did I do something wrong with OpenHAB? is there anything I can do to make OpenHAB find the 4lights switcher as a node?

I will try to keep an eye on this. I look for the following, in order

  1. On the Device page look at the bottom for the date “last exported on”
  2. Look on GitHub at the latest commit date to make sure is is later than above.
  3. Look here at the date for the latest binding jar file (last successful build) after the above date.

You can then update the binding. What version of OH are you currently running?

1 Like

I installed OpenHAB 2.4.0

OK, the easiest way to update the binding, when it is available is through @5iver’s script. MAke sure OH is running so it can uninstall your existing binding. After installing the new binding, delete the Thing from OH and rediscover.

1 Like

Muchas Gracias :slight_smile:

1 Like

Continuing the discussion from [ZWAVE] Lumi switch LM-SxZW showing as Unknown Device:

Thank you, but this script is hard to use for a noob like me with no programming skills.
If I delete the OpenHab folder from my Mac and reinstall OpenHab again, will it forget the old z wave binding and install the new binding with support for the Lumi switches?

Also, do you have any idea if I can reset to factory settings my Philio USB Z-Wave Controller (model PAU01), so that it forgets all previous paired devices?

@chris @Bruce_Osborne

Actually the script should make it easier for noobs.
If it does not work for you uninstall the current zwave binding, download the zwave snapshot binding
https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/
and drop it into your addons folder. You may have to restart openHAB.

No. You need to change the zwave binding version to a recent snapshot version.

Sure, do a hard reset on your stick:
grafik
You need to call the controller Thing and then use advanced settings in HABmin (maybe available in PaperUI also)

2 Likes

You do not need to reset your zwave network to use a newer binding. You can just delete the device things from HABmin and rediscover them. They will be rediscovered with the same thingid so the rest of your configuration will work without changing.

Thank you for the detailed explanation.

I uninstalled the ZWave binding, shutdown OpenHAB, copied the 2.5.0 snapshot into the Addons folder, and restarted OpenHAB.
Once restarted, in the Configurations/Things tab I’m seeing the Zwave Serial Controller as “UNINITIALIZED” and on the Addons/Bindings tab the Zwave binding is not shown as installed.

Have I missed something?

Since tyou just copied in the binding, I think there is another depencency if you are running OH 2.4. That’s why I generally recommend the script. I remember chasing down the missing dependency when I used a snapshot binding on 2.5M1.

Based on quickly looking at the script, you may be missing this dependency needed in the addons folder. You should see errors in the openhab log.

http://central.maven.org/maven2/org/apache/servicemix/bundles/org.apache.servicemix.bundles.xstream/1.4.7_1/org.apache.servicemix.bundles.xstream-1.4.7_1.jar

If it’s not too much trouble can you explain how I should execute the script?
I followed [5iver] link to the github project of openHAB-utils.
From reading the README.md text, I understand I need to copy the zzManualInstall.sh file into the addons folder and then run this command using terminal to execute the script:
bash zzManualInstall.sh --ACTION zwave --ZWAVE_BRANCH development

Is this right?

I didn’t find an option to download the zzManualInstall.sh file from github, so I copied the file content from github and created a .sh file by that name using Brackets app, and I saved the file into the addons folder.
Then I tried to execute the bash command in terminal within the Addons folder, but I got a message: bash: ./zzManualInstall.sh: No such file or directory

I will need to look at that when I get home. I am currently at work in the eastern US.
Since I am running 2.5M2 I am not sure the script will work.

1 Like

Thanks

I learned how to run the script and I got it’s UI with all the options to choose within Terminal.
First I chose to uninstall the ZWave binding. Then I ran the script again and chose to install the ZWave binding. I tried installing both the snapshot and later the development version, but in both cases, once I restart OpenHAB the ZWave binding is not shown as installed and the version written is still 2.4.0 (see attached photo).

@5iver This is your script. Any ideas?

1 Like

@5iver your assistance will be much appreciated.

When I get to this, I’ll update the topic for the script. The readme has manual steps to DIY the install.