[SOLVED] ZWAVE stick is stuck on Initializing, and won't go online


i have problem adding zwave stick (EVERSPRING SA413-1) i’m using openhab 2.4 on raspberry pi 3, after connecting the stick to the USB port, it discover the stick, and i added it as thing, but it stuck on Initializing, tried to remove and re-added, and also uniinstall and reinstall the zwave binding, and also rebooting, nothing help, and it always stay on Initializing.

please help, thanks

the log

2018-11-27 13:35:23.257 [.ItemChannelLinkAddedEvent] - Link 'zwave_serial_zstick_512_serial_can-zwave:serial_zstick:512:serial_can' has been added.

2018-11-27 13:35:23.326 [.ItemChannelLinkAddedEvent] - Link 'zwave_serial_zstick_512_serial_oof-zwave:serial_zstick:512:serial_oof' has been added.

2018-11-27 13:35:23.360 [.ItemChannelLinkAddedEvent] - Link 'zwave_serial_zstick_512_serial_ack-zwave:serial_zstick:512:serial_ack' has been added.

2018-11-27 13:35:23.478 [.ItemChannelLinkAddedEvent] - Link 'zwave_serial_zstick_512_serial_cse-zwave:serial_zstick:512:serial_cse' has been added.

2018-11-27 13:35:23.718 [.ItemChannelLinkAddedEvent] - Link 'zwave_serial_zstick_512_serial_nak-zwave:serial_zstick:512:serial_nak' has been added.

2018-11-27 13:35:23.831 [.ItemChannelLinkAddedEvent] - Link 'zwave_serial_zstick_512_serial_sof-zwave:serial_zstick:512:serial_sof' has been added.

2018-11-27 13:35:27.709 [hingStatusInfoChangedEvent] - 'zwave:serial_zstick:512' changed from UNINITIALIZED to INITIALIZING

2018-11-27 13:35:32.668 [WARN ] [core.thing.internal.ThingManagerImpl] - Initializing handler for thing 'zwave:serial_zstick:512' takes more than 5000ms

update, i see this in the log now

2018-11-27 14:06:01.383 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port 

==> /var/log/openhab2/events.log <==

2018-11-27 14:06:01.392 [hingStatusInfoChangedEvent] - 'zwave:serial_zstick:512' changed from ONLINE 
to OFFLINE (BRIDGE_OFFLINE): Controller is offline

2018-11-27 14:06:03.401 [hingStatusInfoChangedEvent] - 'zwave:serial_zstick:512' changed from OFFLINE 
(BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): Serial Error: Port {0} is 
in use

usb port?

I had a somewhat similar issue, however my Z Stick had already been initialized by the binding previously. I upgraded to the latest snapshot a few days ago and noticed my Z Stick would not come online. Mine would go from Initializing —> Offline —> Port in Use in the error logs. Tried all the steps you did. Restarting the zwave bundle from karaf, restarting openHAB, restarting my PI, re-installing the zwave binding, etc.

Perhaps coincidence because a restart should have cleared the port, but these steps immediately brought my Z Stick online after an openhab restart.

ps -lt ttyACM0

I didn’t have any process ID’s populate that were using the port so I then ran this command

fuser -k /dev/ttyACM0

Again, this may only be helpful if you have already paired the Z Stick or have had something previously using that tty port.

1 Like

i solve the problem by going to sudo openhabian-config > Serial Port > and i remove the check mark from " Add common serial ports to openHAB" and check mark it again