[SOLVED] Zwave stick - Serial Error: Port /dev/ttyACM0 does not exist

I am on ODROID C2 with ARMBIAN 5.60 stable Debian GNU/Linux 8 (jessie) 3.16.57-odroidc2

I followed the installation but I have Serial Error: Port /dev/ttyACM0 does not exist error.

What to check?

  • sudo adduser openhab dialout OK
  • sudo adduser openhab tty OK
  • EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0" OK
  • Reinstalled binding OK
  • Rebooted OK
  • Check dmesg for device name OK

Have you set your symlinks?

Done. Same error on /dev/USBzwave

sudo adduser openhab tty?

Yes, done (not useful for zwave stick)

Well, in three years of using zwave it never harmed :sunglasses:

1 Like

Tried this in karaf?

openhab> feature:install openhab-transport-serial

Works! Where did you foind it?

It was an issue while we were running the development version of the Z-Wave binding for about a year (and a half?). Had to re-install the feature almost every time the binding was updated.
After the merge to 2.4 it was no longer an issue.

I just thought I recognised the log entries :slight_smile: