[SOLVED] Zwave, unknown device NEO Coolcam power plug

Tags: #<Tag:0x00007f433e863138> #<Tag:0x00007f433e862ff8>

There appear to be two devices with the same IDs and overlapping versions -:
image

The bottom 2 are ok since they are different versions of the same device, but the top one has no version, so it overlaps. We need to have a look through and see if it’s still like this, or if one of these has been deleted - deleted things in the database won’t actually be deleted in the binding, so this could cause this to happen. Or, it could be a bug in the check of versions in the database…

1 Like

This made me think. Yesterday it worked with the physical button on the poweroutlet, this morning that didn’t work eather.
I unplugged it and plugged it in again (I think I did that this morning also) and now it works.

Clearly something is not as robust as it should be. (or maybe it needed some sort of reset???) In anycase, the important info for you all is that the software does what it is expected to do…and the hardware, at least for the moment, is also working.

Thx for all support!

Don’t hesitate if you need me to test/do something to sort this last database-issue.

Grts,
Mario

I know it is extreme, but try excluding it from the network and performing a hardware reset of the device before re-including. I had a NEO CoolCam device where a reset was needed to resolve unusual behavior.

Thx for the tip. I’m going to do that. I need to know whether I can trust this device. I’m planning to use it on my waterpump…it will be a backup check but still I would like to know whether it can be trusted.

All I can say is I have 3 and have not experienced an issue with them yet. I have the US version though.

Thx, I looked through my emails and found:

A user request on 2019/09/26 to change firmware versions:

{
    "database_id": 1014,
    "label": "NAS-WR01ZE",
    "manufacturer_name": "Shenzhen Neo Electronics Co., Ltd",
    "manufacturer_id": "0258",
    "device_ref": [
        "0100:1027",
        "0200:1027"
    ],
old:    "version_min": 2.32,
new:    "version_min": 2.21,
    "version_max": 2.32,

which you reverted during approval to

{
    "database_id": 1014,
    "label": "NAS-WR01ZE",
    "manufacturer_name": "Shenzhen Neo Electronics Co., Ltd",
    "manufacturer_id": "0258",
    "device_ref": [
        "0100:1027",
        "0200:1027"
    ],
old:    "version_min": 2.32,
old:    "version_max": 2.32,
new:    "version_min": 0,
new:    "version_max": 255.255,

for reasons I don’t know (I don’t remember any forum discussions about either of those changes).

Hi @mariofrombelgium,

Since the device was recognized by the binding, I did not experience any issue anymore.
I have two more powerplugs on the shelf and will implement them soon. They will be on the tree lighting (it’s almost xmas after all :wink: ). They will be switched through a rule based on astro-binding sunset / sunrise. I’ll let you know once done! (have to do some physical wiring first).

/Jasper

1 Like

I’m running now on openhab3. I have 2 NEO Coolcam power plug, and they work fine. Yesterday I received 2 new ones, they look only a bit different but both are not recognized, it says unknown device.

Maybe there’s a new firmware installed? In Openhab3 I don’t know where to find the information about the firmware version or Type/ID

I’ve heard that the NEO Coolcam devices can be flaky, so you may need to wake them many times to get them to be recognized. If not, here’s the guide for checking and updating the database.

Changes will be merged into a future snapshot binding, which you can install manually.

Note the latest comment about how to make the script work in OH3.

The first link says:

“Devices are identified in the database by 4 pieces of information that are provided by the device during the initial discovery process.”

Where can I find

Manufacturer ID
Device Type
Device ID
Firmware version

in openhab3?

It’s in the userdata/zwave folder.

1 Like

Thank you, found that folder. But the 2 new wall plugs are not listed, in openhab I get a node number, and it says online when it is online, and offline when I pull it out, but unknown device and in the zwave folder both are missing.

You might need to delete the thing and try readding it to get it to initialize. I’ve had to do that multiple times with some battery-powered devices.

I have never heard of a battery operated power plug :face_with_raised_eyebrow:

I have found that for some of my cheap coolcam devices they actually needed to be factory reset before they would include properly into the network. If you are going to do that , try excluding them first in the hope you do not end up with zombie nodes in your network.

2 Likes

Oops.

That being said, you’ll appreciate this nugget from a CES announcement earlier today.

Signify is releasing a Philips Hue wall switch module that upgrades existing switches to smart units. The add-on not only keeps lights available regardless of the switch position, but lets you specify what happens when someone toggles that switch.

It’s also battery-powered, so you’ll need to dismantle your switches every five-plus years to keep the module running.

I’m assuming that this was done so that it doesn’t need a neutral wire, and that Signify’s engineers failed to adequately explain it to the people who wrote the press release.

If it fits in the electrical box, what happens with those older grounded metal electrical boxes? They should block the RF signal pretty well…

1 Like

That was it, factory reset and after that it worked. Thank you.

I hope you have better luck with Neocam than me. I have already replaced one sensor due to being a battery hog. I am getting ready to replace another because at times it fails to detect motion.

Actually I like Neo Coolcam, I had already 2 power plugs for 2 years now, I never had a problem.

I have as well 2 power plugs from fibaro, and they need to be reset from time to time because they stop working.

I have not used my power plugs much but I suspect weak radio reception. The plugs I used with the Christmass tree lights worked much better than the Zooz one the previous year. It decided it was overloaded with just the tree leds and an led star. They replaced it with a heavier duty model. The Neocam one worked flawlessly though.