[SOLVED] Zwave, unknown device NEO Coolcam power plug

Thanks - others also help a lot - especially @sihui and @Bruce_Osborne with database work which really helps :slight_smile:

2 Likes

The thank you post is for all who are dedicating their time to develop, maintain OpenHAB and all the community members who are supporting each other. It’s just wonderful to be part!

/Jasper

4 Likes

Hi @JdeJong, Before I launch a new post with my issues I’m having with this new Neo Coolcam power Plug I would like to know whether you had to make some adjustments to the plugs before they worked properly.

After upgrading my Z-wave binding to the current snapshot it looked like it was working properly.
Now I have all items available for linking.(was not the case before)

The swith item however does not turn off the poweroutlet. I hear the plug switching (when I toggle the switch from within openhab) but the light stays on.
In other words the communication between controller and plug seems to work (I hear the click in the plug) but the result is…nothing.

The Volt measurement item shows that there is 220V “pulled” from the plug but when I turn off the light, by means lightswitch, the output of 220V does not change. However when I toggle the switch of the Neo Plug(from within openhab) then the output of the Volt measurement gets toggled between 0 and 220V

What am I overlooking?

Grts,
Mario

I succesfully updated the z-wave binding.
When rediscovering the Neo Coolcam Power plug I instantly got the necessary items available for linking. So that looked like “problem solved”.

However, the plug behaves strange (see my post just before this one)

Now I notice that there are two lines of this device( NAS-WR01ZE) in the database. When I go over the parameters I see that the “second one” (not sure how I can see the difference) has the parameters set as described in the manual.

So to me that looks like my thing is “linked” to the wong device in the database…?
Is that possible? Of so, how can I solve the issue?
Or do you see another cause?

Regards,
Mario

Please post your xml file.

network_e535530e__node_6.xml (10.5 KB)

This is your device according to your xml file:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1014

Link the switch_binary channel to a switch item:

Switch Neo_PowPlug { channel="zwave:device:controller:node6:switch_binary" }

Make sure you have deleted the Thing and readded it (don’t exclude).
If it does not work post a debug log showing the switch action.

Edit: corrected link to the database

1 Like

Hi sihui,

I basically returned from an update to the snapshot so I had to rediscover the thing from. Also the swotch_binary was linked to a switch.

Anyway I just deleted the linked items and after that also the thing itself. Did a new discovery and linked the switch_binary to a switch item.

Same result!

This is the Logfile as of the newly discovery:NeoCoolCamPowerPlug.txt (43.6 KB)

I can’t see anything wrong, it sends the command, the controller receives the command and the state is updated:

I can only suspect a hardware error:

The swith item however does not turn off the poweroutlet. I hear the plug switching (when I toggle the switch from within openhab) but the light stays on.

1 Like

I’ve found something which looks strange to me but we need @chris to take a look:

The users xml (recent snapshot binding, thing deleted and readded) shows:

<manufacturer>0x258</manufacturer>
<deviceId>0x1027</deviceId>
<deviceType>0x200</deviceType>

That corresponds to this entry in the database:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1014

When I take a look at the openhab2 xml export from the database for that device it shows this thing type id:

<thing-type id="shenzhen_coolcampwrplug_00_000" listed="false">

Looking at github this corresponds to:


which shows:

<property name="manufacturerRef">0100:1027,0200:1027</property>

But when taking a look at the users recent debug log:

the thing type id is
2019-11-18 11:38:03.467 [DEBUG] [wave.discovery.ZWaveDiscoveryService] - NODE 6: Device discovery resolved to thingType zwave:shenzhen_nas-wr01ze_00_000

for that we have only this in the database:

-> <property name="manufacturerRef">0200:1027</property>

I’m confused :sunglasses:

@mariofrombelgium, please again verify which zwave binding is active, go to Karaf and type:

bundle:list | grep -i zwave

and post the result.

217 ? Active ? 80 ? 2.5.0.201911180710 ? openHAB Add-ons :: Bundles :: ZWave Binding

There appear to be two devices with the same IDs and overlapping versions -:
image

The bottom 2 are ok since they are different versions of the same device, but the top one has no version, so it overlaps. We need to have a look through and see if it’s still like this, or if one of these has been deleted - deleted things in the database won’t actually be deleted in the binding, so this could cause this to happen. Or, it could be a bug in the check of versions in the database…

1 Like

This made me think. Yesterday it worked with the physical button on the poweroutlet, this morning that didn’t work eather.
I unplugged it and plugged it in again (I think I did that this morning also) and now it works.

Clearly something is not as robust as it should be. (or maybe it needed some sort of reset???) In anycase, the important info for you all is that the software does what it is expected to do…and the hardware, at least for the moment, is also working.

Thx for all support!

Don’t hesitate if you need me to test/do something to sort this last database-issue.

Grts,
Mario

I know it is extreme, but try excluding it from the network and performing a hardware reset of the device before re-including. I had a NEO CoolCam device where a reset was needed to resolve unusual behavior.

Thx for the tip. I’m going to do that. I need to know whether I can trust this device. I’m planning to use it on my waterpump…it will be a backup check but still I would like to know whether it can be trusted.

All I can say is I have 3 and have not experienced an issue with them yet. I have the US version though.

Thx, I looked through my emails and found:

A user request on 2019/09/26 to change firmware versions:

{
    "database_id": 1014,
    "label": "NAS-WR01ZE",
    "manufacturer_name": "Shenzhen Neo Electronics Co., Ltd",
    "manufacturer_id": "0258",
    "device_ref": [
        "0100:1027",
        "0200:1027"
    ],
old:    "version_min": 2.32,
new:    "version_min": 2.21,
    "version_max": 2.32,

which you reverted during approval to

{
    "database_id": 1014,
    "label": "NAS-WR01ZE",
    "manufacturer_name": "Shenzhen Neo Electronics Co., Ltd",
    "manufacturer_id": "0258",
    "device_ref": [
        "0100:1027",
        "0200:1027"
    ],
old:    "version_min": 2.32,
old:    "version_max": 2.32,
new:    "version_min": 0,
new:    "version_max": 255.255,

for reasons I don’t know (I don’t remember any forum discussions about either of those changes).

Hi @mariofrombelgium,

Since the device was recognized by the binding, I did not experience any issue anymore.
I have two more powerplugs on the shelf and will implement them soon. They will be on the tree lighting (it’s almost xmas after all :wink: ). They will be switched through a rule based on astro-binding sunset / sunrise. I’ll let you know once done! (have to do some physical wiring first).

/Jasper

1 Like

I’m running now on openhab3. I have 2 NEO Coolcam power plug, and they work fine. Yesterday I received 2 new ones, they look only a bit different but both are not recognized, it says unknown device.

Maybe there’s a new firmware installed? In Openhab3 I don’t know where to find the information about the firmware version or Type/ID

I’ve heard that the NEO Coolcam devices can be flaky, so you may need to wake them many times to get them to be recognized. If not, here’s the guide for checking and updating the database.

Changes will be merged into a future snapshot binding, which you can install manually.

Note the latest comment about how to make the script work in OH3.