Some KNX2 Items do not work as expected

Hi again
I have defined a couple of Items with their respective GA. Now when I am using an item that has no actuator as target but sets a Status on some devices, this worked with KNX1 without Problems. With KNX2 neither Type switch nor Type switch-control does work. Any ideas what I am doing wrong?


knx.items (Anwesenheit and Abwesenheit are not working)

Thing device GENERIC "Scenes and Commands" @ "KNX" 
                        Type    number-control  :               Scenes                          "Szenen"                                [ ga="17.001:0/1/0" ]
                        Type    switch  :                     	Anwesenheit                     "Anwesenheit"                           [ ga="0/0/8" ]
			Type    switch  :               	EsIstTag                        "Tagobjekt"                             [ ga="<0/0/13" ]
                        Type    switch  :               	Abwesenheit                     "Abwesenheit"                           [ ga="0/0/14" ]
                        Type	switch	:		        HeizungEinAus			"Heizbetrieb"				[ ga="0/0/26" ]
                        Type    switch-control  :               BeschattungHausAlles            "Beschattung Haus"                      [ ga="4/0/0" ]
                        Type    switch-control  :               BeschattungOst          	"Beschattung Ost"                       [ ga="4/0/1" ]
                        Type    switch-control  :               BeschattungSued                 "Beschattung Sued"                      [ ga="4/0/2" ]
                        Type    switch-control  :               BeschattungWest                 "Beschattung West"                      [ ga="4/0/3" ]
                        Type    switch-control  :               BeschattungSperren              "Beschattung Sperren"                   [ ga="4/0/15" ]
                        Type    switch-control  :               BeschattungAbsolutePosSperren   "Beschattung absolute Pos. sperren"     [ ga="4/0/16" ]
                        Type    rollershutter-control  :        RLHausAlle 		        "RL_Haus_Alles"                         [ upDown="3/1/16", stopMove="3/2/16", position="5.001:3/3/16+<3/5/16" ]
                        Type    rollershutter-control  :        RLEGAlle        	        "RL_EG_Alles"                           [ upDown="3/1/33", stopMove="3/2/33", position="5.001:3/3/33+<3/5/33" ]
                        Type    rollershutter-control  :        RLOGAlle            	        "RL_OG_Alles"                           [ upDown="3/1/32", stopMove="3/2/32", position="5.001:3/3/32+<3/5/32" ]
                        Type    rollershutter-control  :        RLOstAlle   	                "RL_Ost_Alles"                          [ upDown="3/1/17", stopMove="3/2/17", position="5.001:3/3/17+<3/5/17" ]
                        Type    rollershutter-control  :        RLSuedAlle                      "RL_Sued_Alles"                         [ upDown="3/1/18", stopMove="3/2/18", position="5.001:3/3/18+<3/5/18" ]
                        Type    rollershutter-control  :        RLWestAlle                      "RL_West_Alles"                         [ upDown="3/1/19", stopMove="3/2/19", position="5.001:3/3/19+<3/5/19" ]
                        Type    switch  :                       ZentralAusEG                    "Zentral-Aus EG"                        [ ga="0/0/4" ]
			Type    switch  :                       RLBibliothekSperren	        "RL Bibliothek sperren"                 [ ga="7/3/35" ]
			Type    switch  :                       RLGaesteSperren                 "RL Gästezimmer sperren"                [ ga="7/3/36" ]


Switch Anwesenheit "Anwesend [MAP(]" &lt;present&gt; (gTime) { channel="knx:device:KNXRouter:GENERIC:Presence" }
Switch LaengerAbwesend "Längere Zeit abwesend [MAP(]" &lt;present&gt; (gTime) { channel="knx:device:KNXRouter:GENERIC:Absence" }

And now I am back to where I had been with the KNX2 binding within 2.3 stable… Nothing works anymore. I can do a reboot but the KNX side of things now does simply nothing at all. Whatever key I am pressing, it results in absolutely nothing in the Events.log or in Openhab.log. I ran into this problem already some weeks ago and decided to wait until 2.4. As so many people are reporting stable funtction with the 2.4 nightly, I spent the entire day migrating the stuff. Until some minutes ago, besides a handful of items, everything else was working pretty well. And now, all of a sudden, the KNX part has stopped working entierely.

I have no idea why this KNX2 Thing runs for some People quite well and causes such pain for others like me…

Switch Anwesenheit "Anwesend [MAP(]" <present> (gTime) { channel="knx:device:KNXRouter:GENERIC:Presence" }
Switch LaengerAbwesend "Längere Zeit abwesend [MAP(]" <present> (gTime) { channel="knx:device:KNXRouter:GENERIC:Absence" }

As you are using Presence and Absence as channels, no wonder that this does not work?!?

Type switch  : Anwesenheit "Anwesenheit" [ ga="0/0/8" ]
Type switch  : Abwesenheit "Abwesenheit" [ ga="0/0/14" ]

So that means…? Not sure what it is you are trying to tell me… you are very good in this KNX stuff I know, so please forgive me when I have no idea why this would be wrong…It worked like that with KNX1 perfectly…
These Channels are in use on the KNX side as well, switching them with my MDT Rockers.


Switch Anwesenheit "Anwesend [MAP(]" <present> (gTime) { channel="knx:device:KNXRouter:GENERIC:Anwesenheit" }
Switch LaengerAbwesend "Längere Zeit abwesend [MAP(]" <present> (gTime) { channel="knx:device:KNXRouter:GENERIC:Abwesenheit" }


You are linking the items to non-existing things? Ok, now you confused me completely :slight_smile:

Can’t check currently. As stated in my former post, the entire KNX binding has stopped working currently. Will give it a try in a day or so, hoping the binding want’s to Play then again

No, Please take a look at your own thing definition in this posting Some KNX2 Items do not work as expected

Thanks a thousand times for explaining my error to me, it works now!!
The other two GA which did not work were caused by a number-typo in the respective GAs. So now everthing seems to work again. No idea why the System stopped entirely last night. today it’s back to operational mode.

So the only issue I am left with is, that some percentage-values are not shown correctly.

Number HeizungWoZiStellwert						"Stellwert [%.1f %%]"							<qualityofservice>	(gHeating,gTempWohnen)	{ channel="knx:device:KNXRouter:HA1MDTREG:Channel08" }

This had been working with the KNX1 binding, showing the correct percentage. With KNX2 it shows the decimal value (so 0.6 instead of 60% f.e.). I have tried to define the DPT (5.001) which did not change anything. Any ideas what the problem might be here?

As a workaround, try out to link the number channel to a dimmer Item :slight_smile: Of course you have to use the Text widget for display only…

That didn’t work out. Using a dimmer (in KNX.items as well as the heating.items and the sitemap) did not deliver any value at all.

Other ideas ? :slight_smile:

I am trying to undertstand why the DPT (which is supported) is obviously responding in the wrong format…

Nobody else experiencing this ?

In fact a Number Item is not of percent Type.

The weather widget shows probabilities and humidity as percentages in number items, so whats different here? With knx 1 this worked as well… how should I define the percentages for knx2 items then, please?

Ah, there is in fact annother thread about this, didn‘t see that before.

Finally solved it with the help of lewi: Item AND thing need to be defined as DIMMER. In my tests after your suggestion, I made the mistake to only change one, not both.