Somfy Tahoma and OpenHAB2

somfy
tahoma
Tags: #<Tag:0x00007fe05ebbd758> #<Tag:0x00007fe05ebbd3e8>

(Pascal Horn) #1

Hey There!

I have an problem with my current OpenHAB / Tahoma installation.
If I send a command to Tahoma, where some of my rollershutters are only 1-way, Tahoma keeps loading and loading the current state of the shutter but the shutter has moved completely. (See in the picture)

The Problem now is, that if i send another command to tahoma nothing happens. The rule of openHAB is working fine.
My first solution to that was to send a “STOP” in front of everything else, but thos leads to another problem: If the shutter is idle the “STOP” is interpreted as the “MY Position” Command and the shutter moves but not where it should be.

When roller shutter-like thing receives STOP command two possible behaviours are possible

  • when the roller shutter is idle then MY command is interpreted (the roller shutter/exterior screen/awning goes to your favourite position)
  • when the roller shutter is moving then STOP command is interpreted (the roller shutter/exterior screen/awning stops)

Source: https://www.openhab.org/addons/bindings/somfytahoma/

My system is a raspberry pi 3+ but I think this does not matter in this case…

Do some of you have a soution or further questions for that?

Thank you!

Tech


(Vincent Regaud) #2

Hello, @TechCraft

Please see:


And provide info about #8, #9 and #11

Thanks


(Pascal Horn) #3

Thanks! I’ve elaborated some more. Hope it helps.