Somfy TaHoma Developer Mode

I’m using Openhab 4.0.0 with the “Somfy
Connectivity kit-box (2024.2.4-2)” with “Somfy Tahoma Binding”. The link between Openhab and the box is via Wifi. For a year now, I’ve been controlling 12 shutters.
I’m getting more and more connection errors with the message “Too many requests” in the log.
I’d like to use the “Developer Mode” that I can easily set up. But I’m still getting “connection error”.
Is “Somfy Connectivity kit-box” compatible with “Developer Mode”?

Hi. It is not compatible. According to this thread on GitHub, it will never be Support of Connectivity Kit · Issue #12 · Somfy-Developer/Somfy-TaHoma-Developer-Mode · GitHub.

I’m having the same error, but it only started appearing recently. I’m trying to increase the polling rate from 10 to 30s to see if that makes a difference.

Kind regards

Hello, thank you for your feedback. I’ll stay with the cloud option. I’m also going to work on the parameters. I’ve set refresh to 90, Status timout to 60. In the event.log I find the following message every 5 minutes.

2024-06-11 09:05:35.470 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘somfytahoma:bridge:f3c64b10b0’ changed from OFFLINE (COMMUNICATION_ERROR) to OFFLINE (COMMUNICATION_ERROR): Too many requests, try again later : login with …

I’m convinced that tohamalink.com is at fault.

Hello, I’ve just realized that the software version of my connectivity kit was updated on June 4th. Since that date, OpenHab programming no longer works properly. Can you check the update level of your connectivity box. Dan

Hello, after contacting Somfy service I obtained the following information: the number of daily connections is now limited to 30. Beyond that the account is black listed. I’ve set the binding bridge Refresh and Status Timeout variables to 3600 and everything’s working fine now.