Somfy ... What Hardware für openhabiab on raspy

I have an awning whose motor is controlled by a somfy remote … With what kind of hardware can I connect this to my openhab (openhabiab on raspberry)? For my ZWave shutters there was/is a usb stick…m but for the somfy?

You can use a TaHoma or Connexoon box. Can be linked to OH

In case the awning uses io homecontrol you might want to consider a Velux KLF200 gateway. This has the benefit of local (LAN) control and not dependent on the Somfy cloud service.

For Somfy RTS you can use the RFXCOM RFXtrx433XL
And use in addition a lot of 433.92MHz devices and sensors.

rs485 works great and easy to connect by UART-rs485 interface

I use Somfy MyLink. Pricey and cloud based. Works well.


now I remember something else: my Openhab-Raspi is in the staircase/basement … if I now connect e.g. the RFXCOM RFXtrx433XL (via USB if I see it right) … is it more likely or unlikely to reach the awning on the first floor (as the crow flies about 4m, but also 2 brick walls)?
Had to me so far no worries, because my ZWAVE and ZIGBEE - receivers simply pass your signals simply …

Mmh, the more I think about it: has anyone ever replaced the receiver of a Somfy awning against “something else” (e.g. a ZWAVE-RollerShutter module)? Does something like that make sense?

If you can control the Somfy motors with the Somfy remote on the location where you want to install the RFXtrx433XL you will also be able to control the motors with the RFCXtrx433XL on that location.
If the distance is to large you can connect the RFXtrx433XL to a Raspberry PI and install ser2net. This way the RFXtrx433XL can be connected via LAN.

ser2net installation on Linux with the RFXtrx433XL on port 10001:
Disable Serial Console (if configured)

sudo nano /etc/inittab
insert a # sign in front of this line:
T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

Remove console (if configured)

sudo nano /boot/cmdline.txt
delete these 2 fields: console=ttyAMA0,115200 kgdboc=ttyAMA0,115200

Add ser2net

sudo apt-get install ser2net

sudo nano /etc/ser2net.conf
10001:raw:0:/dev/ttyUSB0:38400 8DATABITS NONE 1STOPBIT

sudo /etc/init.d/ser2net restart

Autostart ser2net

sudo nano /etc/rc.local

add the next line before exit o :
/usr/local/sbin/ser2net -n