SONOFF trouble - SONOFF T1 UK Switch


I have a sonoff T1 UK switch (1CH). The board inside says SONOFF T1 R2 UK TOUCH BOARD VER: 1.0

I have not been able to flash it - initially it went half way then ‘died’. I don’t know where the GPIO pin is in order to force it into flash mode.

Any/all help appreciated

Sonoff T1 UK board

Here you can see the location of GPIO0 on your sonoff. I flashed one some days ago using this image.
Hold a GND wire on that SMD resistor when powering on the board with 3.3V and it will be fine.


Thank you! :slight_smile: I have previously tried to flash using sonOTA and that failed. Since then, no luck. I’ve tried two different models. I’ve connected the 0v to the GPIO0,but seems like I’m doing something wrong as I’m not able to get it into flash mode.

Any suggestions?


ok, I have managed to flash a couple of 'em now - however, the one T1 does not go into AP mode — it flashes without an issue, but no other way to connect/configure then? Any suggestions?


Check the serial logging for information.

Hi thank you for the reply. Any idea how I should go about to see this?



OK digging back, I remembered PUTTY had something about serial ports- anyway, long story short, I did as you suggested. The output to the screen is a lot of garble, and does not make sense.

I did connect using the same specifications used to flash the device.

Any other suggestions?