Sonos binding not working

Hello All,

I have configured the SONOS v1.9 binding on my OH1 install and I cant get it working. I have used the Windows UPnP Tester application to get the UUID for the devices, I then configured the devices in the openhab.cfg and then created a simple items file for one player to adjust volume and turn on/off.

Do I have to add anything else, I have read it uses the UPNP library, how can I check if that is installed and running?

I also noticed that the players had _MS on the end of the UUID but none of the examples showed that, should this be included or left off?


It might help to post what you have in your openhab.cfg, item file, and sitemap. It could be a simple syntax issue.

OK, here is the openhab.cfg :-


Here is the item file contents :-

Group gSONOS            (All)

Group P1_Sonos          "Sonos Play1"           <network>       <gSONOS>

Switch SP1-Room-S "Room Play/Pause"    <network> (P1_Sonos) { sonos="[ON:P1_room:play], [OFF:P1_room:stop]" }
Dimmer SP1-Room-V "Room Volume"        <network> (P1_Sonos) { sonos="[P1_room:volume]" }
String SP1-Room-R "Room Station [%s]"  <network> (P1_Sonos) { sonos="[P1_room:radio]", autoupdate="false" }

May be a silly one,but have you tried restarting OpenHAB?

Hmmm… nothing jumps out at me. Did you try removing the “_MS” from the RINCON?

I use the OH2 binding but it should be very similar.

An udn with only 000000… And _MS at the end is strange to me.
You should be able to find the correct udn with Sonos command:

I did try restarting, also tried with the _MS removed.

The UDN listed is not my actual UDN, I just changed it all to zeros for the forum, thanks for the links I will check the UDN from there to see if it matches.