Sonos Binding Notification


(Michael) #1

Hello Community,

i have a problem regarding the Songs Binding. I am using a Sonos One with Alexa. When i trigger a Notification Sound (Doorbell.mp3 in html folder) Music from Spotify is stopped and the Doorbell Sound is played. But its not continuing the playlist that was played before. That makes me turn on the Music again after somebody rang the bell which is pretty annoying.

This is my Code:

// Klingel Rules File

rule Klingel
 
when Item Klingel changed from OFF to ON
		
then
		
sendCommand(SonosOneOben_BenachrichtigungAbspielen,"http://192.168.178.126:8080/static/doorbell.mp3")
		
		
end		

SonosOneOben_BenachrichtigungAbspielen is connected to sonos:One:RINCON_7828CA19A30601400:notificationsound just like it should i guess.

Any suggestions ? Thanks


(Jürgen Baginski) #2

You should use the “playSound” command as explained Here.
The syntax for setting the audiosink as well is probably the same as for the say command, which is explained on that site as well.


(Marco Schnubel) #3

Like @opus said i am also using the “playSound” command.

playSound("sonos:PLAY3:RINCON_000E587xxxxxxxxxx","alarm.mp3")

alarm.mp3 is saved under/sounds


(Jürgen Baginski) #4

Thanks for stepping in, Yes the syntax for playSound doesn’t need to state the Voice.