Sonos does not say a word

I have read several related topics in the community that seems related to my problem but I could not find a solution yet…

I’m running OH 3.0.2 on a Raspberry Pi 3. I’m planning to let Sonos say notification messages based on OH events. But I’m banging my head with my Sonos One for several days now.

I use the openhab-cli console like this for a test: voice say Hallo

The Sonos One is set as the default audio sink and notification volume set to 10 on the Things configuration page. The TTS seems to work correctly since I find the mp3 file in the cache after issuing the command. I also see the volume of the Sonos going to notification level and back to previous level in the Sonos App as well as in the OH log. I also see state changes of the channels of the Sonos in the OH log. But the weird thing is that I do not here any word… No matter if I play a radio station, a Spotify playlist or if the Sonos stopped when I issue the command - same behavior. I also tried to setup a OH rule for the same purpose - same result. To make things even more weird I did hear a phrase from my Sonos occasionally indeed (maybe once a day). Repeating exactly the same command right after this I was no longer able to hear it again.

I also set the log-level to TRACE for org.eclipse.smarthome.binding.sonos and org.openhab.binding.sonos but I do not see any hint what could go wrong.

Any idea? Your help is very much appreciated - I’m really running out of ideas

It is the karaf console you have to utilize and the command would be openhab:voice say Hello World.
Other then that your setup seems to be as mine ( which is working).
For the TTS files, in order to verify they are correctly created, are you able to play them otherwise (using another PC or the like)?
Concerning the state of the Sonos One when issuing the say command, did you control it via the Sonos App or from elsewhere ( elsewhere could be the reason for the problem).
Did you restart the binding or openHAB?

Hi Opus,

Same result with the karaf console. Interestingly the call seems to randomly come back either immediately or run into a time-out. I found no pattern.

Yes, the TTS file plays correctly on my Mac with iTunes.

Beside Openhab I control the Sonos from the Sonos App only.

I restarted the Binding as well as reboot the Raspi.

Any other idea?

That sounds weird!
Some random questions älthough I am out of ideas!

Are the Sonos devices in the same network as your openHAB server?
Are the Sonos devices on your Wifi Net or on a “Sonos-Net” (i.e. one device is connected by wire)?

ok - I did not provide the full details of my network topology so far since I thought it might not be too relevant. Here it is:

  • Openhab Server (Raspi) is wired to my network using LAN cable to my router
  • Sonos One is connect to a Network-Switch (Apple Time Capsule) by Wifi
  • Sonos Amp is connected by wire to the same Network-Switch as the Sonos One

I did not mentioned the Sonos Amp yet to make things not too complicated (might been a mistake - sorry if so). On the other hand I also tried the setup with the Sonos Amp switched off - same result. I can also repeat the behavior just using the Sonos Amp instead of the Sonos One…

Does that help to track down the problem…

BTW: I use other bindings too to integrate various other Things/Items: HTTP, Hue, iCloud, MQTT, myStrom, MieleCloud, Netatmo, Openweathermap, Remote Openhab, Shelly, Xiaomi - I really love the strength of Openhab to integrate a very heterogeneous system setup…

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.