Sonsor shows on HABmin but not on sitemap

Hi, surely I am overseeing something embaresing simple, but I have been staring at this for a week and cannot get any further. I hope one of you can spot the error.
I have the Secure SRT321 thermostat configured and after about aweek (!) initiated. I run OpenHabian on RaspberryPi2 with Aeotec Z-stick.
The thing shows up in PaperUI and in HABmin it even shows me the sensor value (22.2°C).
But I can not get this number on my sitemap. The same goes for the battery level, but first things first.

PaperUI:

Sensor (temperature)
zwave:device:f4f7d5ef:node8:sensor_temperature
Number

default.items:

Group Verwarming
Number Temperatuur_Badkamer “Temperatuur” (Verwarming) {channel=“zwave:device:f4f7d5ef:node8:sensor_temperature”}

default.sitemap:

Group item=Verwarming icon=“heating-on”{
Frame label=“Verwarming”{
Text item=Temperatuur_Badkamer label=“Temp. badkamer”
}
}

The sitemap is showing:

Verwarming
Temp. badkamer -

I saw that HABmin shows the item-info with underscores in stead of semicollins. I tried this in the items file too, but that does not help. I also tried with and without explicitly setting the ‘view’ with [%.1f °C] but no succes their either.
I hope you guys can help out.

This is the item name for the auto-generated item.
It seems that you have OH2 in Simple Mode for Item linking (PaperUI->Configuration->System) and this created the items and the links for you when you pressed the radio button on the Thing’s channels.

Check in PaperUI -> Configuration -> Things the already linked item names for the channels.

You can use those names in your sitemap.

Hi, indeed I do have simple mode on. I will check tomorrow what happens if I use the names that paperUI shows for things. I was already wondering why I often see more names for one item. Thanx for your reply.

You were right, using ‘item=zwave_device_f4f7d5ef_node8_sensor_temperature’ does work indeed. The Battery level works too after the same treatment. Thanks!

I did not get from the docs that the simple mode means you cannot make your own items-file. Specially since I have several switches that work perfectly although I have made my itemfile and used these in the sitemap.
Now of course I thought to do the same with the temperature setting, but this does not seem to work while it did look like it worked before. This is getting schizophrenic ;-).

Setpoint item=zwave_device_f4f7d5ef_node8_thermostat_setpoint_heating label=“Temp. badkamer”

Any thoughts on this too?

You can have both working in parallel just fine.
One auto-created item from PaperUI and another manually defined in an *.items file.
You will just have 2 different items linked to the same channel… That’s not a problem. Just be careful to use different item names not to create a duplicate/conflicting configuration.

Setpoint is a Sitemap element type to control a compatible item type (like a Number).

What item type is this setpoint_heating? (You can disable simple mode and you can check the items in the left menu under configuration in PaperUI)

It turns out both my battery devices and even one of my four wallplugs loose connection for some times, simetimes days.
The only way to correct this seams to be placing the device near the controler.
Does this mean that the ‘hopping of data’ and ‘mesh building’ is not working for me?

Did you manage to resolve this? I am having problems with seeing the temperature on my SRT321 thermostat with openhab 2.

One major improvement was to put my zwave stick in a powered usb-hub in stead of directly in my pi.
Second, the SRT has very long wake-up time preconfigured. I lowered this to about 5 minutes using habmin. It takes months to get the configuration to the SRT. I gave up first, and then it suddenly started working. Maybe you should give up earlier :wink:. Now it does use more batteries…