Sony Devices Binding

openhab2
Tags: #<Tag:0x00007f0153bbba38>

(Kristof Rado) #476

I’m using the stable 2.2.0 release and I don’t get any errors…
However I can’t even setup the IRCC, and other channels (just the SimpleIP). Restarting the TV and openHab doesn’t help, the discovery can’t find the device.

This is not my main TV and I can live with that I can only use the SimpleIP, because it has all the functionality (turning on-off, channel change, etc…) which I need, but this is really prevents using this binding that TV turns off completely after a few mins. And I think this is not the problem of the binding, because as soon as I turn the TV on from the remote control it connects to the TV. Years before I have tried a mobile app for this TV, but as I can remember it had this same problem, that I was unable to turn on the TV after not using it for ~10 mins.

I just saw that there is a value for which network adapter is used. However is it not so clear that this is the adapter of the TV or how the openhab server connects to the router?


( . ) #477

Do you need any help or testing? I own a sony-kd-49xe8005


(Kristof Rado) #478

I just want to ask that there will be any new to this binding in the new 2.3 stable release? If I’m currently on 2.2?

Also do you have any idea to this problem which I have?

Since then I have restarted several times the TV and openHab as well, but still can’t find it, just simple ip tv works… also it get’s disconnected after I turn TV off.

Thanks!


(Jonas) #479

Hi!

My bining is working nicely even at 2.3.0.
My binding is still at RQST code mode. But it works.
The only issue i have is that my changes of the ignored channels are not saved.
That’s kind of annoying because i don’t want the binding to ignore any …
Maybe this issue goes along with the not saved ignore-configuration.
I don’t know how to get my tv to provide a code i could enter there …


(Kristof Rado) #480

What kind of device do you have?

So that means that you can power your TV on anytime from openHab? My TV always gets disconnected from the internet…


(Jonas) #481

yes. everything’s fine except the issue i mentioned above.
i control: power, volume, amazon, twitch, all channels and even IRCC commands.
if you like i can share my items file


(Killercorny) #482

Since I updated to OH 2.3 the sony binding doesnt show up anymore in paper UI. Marcetplace is active, but I could not find it. Whats wrong?


(Jonas) #483

you can install it manually by copying the provided binding into your addons folder:


(B R) #484

Will this work on Sony projectors? I have one of the VPL-VW285s and I’m trying to add it with no luck.


(Joakim östberg) #485

Hi, i deleted the scalar web thing since I had problems connecting to my TV. I would have hoped for it to show up in the inbox. But to add it as a thing again, I seam to need to manually enter IP, MAC, CODE and MAP. I don’t have a map. Is there a more user friendly way to get Scalar web to work with my Sony TV again?


( . ) #486

Is this binding still under active development? The most recent version dates from november right? https://marketplace.eclipse.org/content/sony-binding


(Micael ) #487

I think not. I am considering my options for getting my vW760 to work with oh, and afaict, the only available option is to write a new dedicated binding. I am tempted, but I fear my java knowledge will mean it will take forever.

Maybe someone has already done something for the Sony projectors? (Open call)


(Tim Roberts) #488

I’m still here - just haven’t touched this in awhile (had some health stuff happen that has created an extended leave). I still plan on getting back to it because the latest version is a HUGE change over what you all have.

Tim


(Adrián Janeiro Lorenzo) #489

Thanks @tmrobert8. I hope you get well soon.


( . ) #490

Health stuff is way more important, hope you get well soon.


Contributing a new binding
(Udo) #491

I am looking for an example of a sony.things file.
Does anybody has configured the sony binding via things-file?


(Kiril Tsvetanov) #492

Man i’m really new to all of this.
I need some help.
I have a Sony TV (from 2018 model) and i managed to run openHAB and my motion sensors are up and running.
Now i need to find a way to controll my TV.
How to discover it ?
How to controll it?
What is a good “sitemap” for TV controll?
What happens when i plase an “addon” in the /addon folder?
How to see if something is working?
I plased an “org.openhab.binding.sony-2.0.0-SNAPSHOT.jar” file there.
So what now ?
How to test?
Do i need to go in localhost and discover it ?
Maybe add same addon from there?


( . ) #493

I think there is no documentation available regarding .thing files for this binding. I added the thing through paperUI and it works fine.


( . ) #494

Adding add-ons:

You could login to the console to check if the bundle/binding is active and if not start it.
https://docs.openhab.org/administration/console.html

Afterwards, in paper ui you can add the thing Be sure the TV is ON.


(scott dee) #495

If you do end up getting it all tied together you’ll need to keep an eye on your openhab.log

I have a 2017 TV (iirc) and after 6 hours or so the binding takes a dump and openhab goes with it.

That’s my experience, yours May differ.